MATLAB Answers


ADAMS 2012 and Matlab 2012 Co-Simulation error

Asked by Pouya Jamali on 16 Jun 2012
Latest activity Edited by Wan Ding on 31 May 2017

Dear all I want to Co-simulate an Adams model provided by MD_ADAMS 2012 x64 with Matlab Simulink r2012a but there is a problem. that is: when I run the Simulink block diagram that contains adams plant I see the following error message>> Error in S-function 'testmecanum/adams_sub/ADAMS Plant/S-Function': S-Function 'adams_plant' does not exist. Any body know how can I overcome this problem?

All the best


Log in to comment.

2 Answers

Answer by Pouya Jamali on 16 Jun 2012
 Accepted Answer

I found it. Here is the solution:

One file is missing from The MD_ADAMS 2012 x64 installation process. you must download it from MSC.Software official website and install it in the recommended path. take a look at this article :


Maybe you should register in first and also log in to watch this hyper link.

Hi pouya jamali I have same problem but with adams 2013.2 Student edition and matlab 2012a on windows 7 x64 when I tried to follow same step in the link you posted I didn't find win64 directory in path "C:\MSC.Software\Adams_Student_Edition\2013_2\controls" there is win32 directory so can you help me please

thank you very much

Sorry for my late reply jone,

I guess you need to find the same file but for a 32-bit platform. search it over simcompanion.

Log in to comment.

Discover what MATLAB® can do for your career.

Opportunities for recent engineering grads.

Apply Today

Win prizes and improve your MATLAB skills

Play today