Clear Filters
Clear Filters

Raspberry PI - "Timeout while receiving data from remote server"

35 views (last 30 days)
Hi, I have this error message :"Timeout while receiving data from remote server" when I use the command "raspi" in the command window. But the ping command is working fine so I'm connected to my raspberry pi.
  2 Comments
Jan Hrabina
Jan Hrabina on 14 Dec 2018
Hi, I have the same problem. The connection to RPi is fine, I am able to connect to it with "raspi" command and control it by shell commands or use raspi object read functions like "showPins". But write functions (writeLED, configurePIN, ... ) ends in error: "Timeout while receiving data from remote server".
Work with PINS/LEDS by shelll commands works OK (system(rpi, 'echo 0 | sudo tee /sys/class/leds/led0/brightness');)
Any reason/solution, please?
Jonathan
Jonathan on 13 Feb 2019
I had the same issue - RPI connection is fine, pinging the Pi works fine, but the writeRead function gives the same timeout error.
Switching off Windows firewall (I'm using Windows 7) completely solves the problem. (Note: switching the Firewall off after connecting using the 'raspi' command doesn't seem to work, it seems I need to switch off the Firewall before that).
Does anyone know how to add an exception in Windows Firewall in order to allow this to work without completely shutting down the Firewall? I have tried adding an exception (both inbound and outbound) for the IP address and port using the procedure shown here, but the problem seems to persist. I can live with switching the Firewall on and off but it's not particularly convenient.

Sign in to comment.

Answers (9)

Oscar Pilloni
Oscar Pilloni on 27 Nov 2018
Had the exact same problem.
TL;DR: Disable your firewall (or make the appropiate rule changes)
Disabled mine, everything works great.

Fabian Schilling
Fabian Schilling on 23 Oct 2018
Edited: Fabian Schilling on 23 Oct 2018
I have the same Problem since three days und five try's to install the support packages. The Connection via Simulink works….

M LaRosa
M LaRosa on 24 Oct 2018
I had the same problem after selecting "Connect directly to host computer" during the "Hardware Setup" of Simulink Support Package for Raspberry Pi Hardware version 18.2.0. I do not get the error message if I select "Connect to wireless network" (depending on what you are trying to do, this might be an acceptable workaround).

Peter Demeter
Peter Demeter on 8 Nov 2018
I have same issue, I tried connect directly and over LAN also, results were same. After "rpi = raspi();" command, SSH doesnt work with default user and password.

Austin Gosling
Austin Gosling on 11 Jan 2019
I have a similar issue since installing R2018B, which then automatically updated the Raspberry Pi Matlab server to version 18.2.1 from 18.1.0. If the connection is left too long without use it times out afterwards. For example, If I do this in a script:
clear dac
clear rpi
rpi=raspi
dac = rpi.spidev('CE1',1,2000000)
writeDAC0(rpi,dac,2.0) % my function that writes to the DAC via SPI
for i=1:100
writeDAC0(rpi,dac,2.0+i/100)
fprintf('%d ',i)
pause(1)
end
It works fine, and if I am fast enough to start the for loop again, it keeps going. If I enter these commands manually, and wait too long after the rpi=raspi command, then the dac = ... command times out. If I enter the rpi=raspi and the dac = ... commands quickly and wait too long for the writeDAC0 command, it times out. If I try the writeDAC0 command again after a few seconds, it times out.
The behaviour is the same if I just try simple commands like rpi.writeDigitalPin, etc.
Timeout message: Timeout while receiving data from remote server
I've tried running a continuous ping in a command shell (Windows), but this makes no difference. netstat -n reports the TCP connection to 18734 active throughout the whole process, whether I time out or not, so I suspect it is somewhere in the matlabIOserver on the Raspberry Pi, or in Matlab on windows.
Everything works fine with no timeouts on R2018A and matlabIOserver v18.1.0.
Working configuration:
  • Windows 64 bit
  • Matlab R2018A
  • Raspberry Pi Model 3 B (not +)
  • server_v18.1.0 on Rapberry Pi
Not working configuration:
  • Windows 64 bit
  • Matlab R2018B
  • Raspberry Pi Model 3 B (not +)
  • server_v18.2.1 on Rapberry Pi
  1 Comment
Jonas DK
Jonas DK on 4 Feb 2019
Edited: Jonas DK on 4 Feb 2019
I am experiencing the same. If I start my script after waiting for too long, it gives the timeout error. If I am fast enough it runs okay (I a talking about blinking the LED...).
I am using 2018b, Raspberry PI model 1B and raspbian v18.2.0

Sign in to comment.


Austin Gosling
Austin Gosling on 28 Feb 2019
Update: disabling the windows fireall for private networks resolved the issue for R2018B

Brian
Brian on 30 Sep 2019
Check out youtube video 'Request Timed Out Fix Windows 10/8/7' this worked for me, without disabling the firewall

Oihan Irazu
Oihan Irazu on 2 Mar 2020
Hi, I am having the same problem. Desactivating the firewalls does not work for me and continueing the video "Request Timed Out Fix Windows 10/8/7" give me error because I am connected with WIFI to Internet I think.
Any other suggestion to try to solve this problem?
Thank you!
  2 Comments
Oihan Irazu
Oihan Irazu on 1 Apr 2020
Yes!
I desactivate the firewalls and then restart the computer. Then everythings works well.

Sign in to comment.


Kyle Mitchell
Kyle Mitchell on 21 Dec 2021
It appears that the Matlab Server running on the PI pings the host computer every 5-7 seconds as a heart beat. If these pings fail the Server on the PI closes the connection.
Allowing ping responces in the firewall for private networks seems to be the fix for this issue.

Categories

Find more on MATLAB Support Package for Raspberry Pi Hardware in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!