MATLAB Answers

Lin Shi
0

About the sync error of psychtoolbox in Mojave! Help!

Asked by Lin Shi
on 13 Nov 2018
Latest activity Commented on by Lin Shi
on 30 Nov 2018
Hi all. I am new to psychtoolbox and am learning for my experiment. I found that in Mojave system (latest OSX system), PTB always get sync error, even if I skip the 'flip' test (VBL), I can't run through. I tried to go through the PTB files which recommended multiple checks including display card settings. However, in OSX system, I cannot find those set options, seemingly they are OpenGL options. I really need to use PTB in my experiments. Does anyone have any idea about this? I will be really thankful.

  4 Comments

Show 1 older comment
Mathworks Technical Support will not assist with PTB (well, they might assist the PTB developers themselves.) PTB is a third party product, and everything about sync is in the PTB provided components.
Ah. Then you need to contact those who wrote the PTB. It may possibly not be fully Mojave compliant.
Thanks John, also thanks Walter. First, my matlab ver is 2018b, PTB ver is almost the latest, 3.0.14. My mac is 2016b Macbook Pro. The reason I am asking here is that it seems PTB developers are expressing sort of depression in their website and some other sites due to poor support from OSX, ("Use of macOS 10.14 is strongly discouraged and officially unsupported at this time." citing from their website). But there are some random replies saying there seems to be a way to get around, but no detailed info was provided. So, instead of searching all possible websites, I just wish to ask here if anyone has successfully run PTB on Mojave, or knows how to fix this. If so, it may possibly be an issue of my mac. So I may need to update my hardware. But from as far as I know, it seems PTB is very poorly supportted on Mojave.

Sign in to comment.

0 Answers