Unable to Update MATLAB on Ubuntu 18.04

87 views (last 30 days)
Austin Cassel
Austin Cassel on 4 Apr 2019
Commented: Obed Rios on 19 Sep 2021
I am running MATLAB R2018b and noticed that update 4 is available from the notification menu. However, everytime I attempt to update, the installer states it does not have write permissions for the folder, obviously. I am unable to give update installer root permissions to update, it is not a huge problem, but the software costing $100 because I am a college student and not able to simply update is a dissapointment. UPDATE: I upgraded to Ubuntu 19.04 and am still unable to give MATLAB root access, I love the program but the community is not helpful.
Austin Cassel
Austin Cassel on 6 May 2019
I have since installed Matlab R2019a and still have the issue, I run Matlab through a launcher provided through the Ubuntu repositories. When I run the above command it returns a license error -9, I have attempted to fix it but it does not run through command line even though everything matches, host ID, username, et cetera. I essentially give-up at this point, if I need an update, I will just download it and reinstall it.

Sign in to comment.

Answers (1)

Bukoko Ikoki
Bukoko Ikoki on 19 Dec 2019
For the current version of matlab, which is R2019b, presuming installation path is default and matlab is not running, try:
cd /usr/local/MATLAB/R2019b/bin/glnxa64
and then:
sudo ./update_installer
Obed Rios
Obed Rios on 19 Sep 2021
Yes, work for me too, R2020b Update 6, Thank you!!

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!