Pushbutton is not responsive until I move figure that pushbutton is attached to

1 view (last 30 days)
Chris Endemann
Chris Endemann on 30 Jul 2019
Commented: Adam Danz on 1 Aug 2019
I am encountering some strange behavior probably due to my lack of experience in designing small GUIs via Matlab.
I built a small menu for selecting some parameters related to the analysis I am running. This menu includes an "Accept" and "Cancel" button at the bottom of the figure.
function acceptButton(hObject, eventdata, handles)
%% set pars from menu AFTER button press
pars=setExptParsFromMenu(menu,pars);
close(menu.FigH)
quitProgram=false;
end
function cancelButton(hObject, eventdata, handles)
%% set pars from menu AFTER button press
close(menu.FigH)
quitProgram=true;
end
Upon hitting accept/cancel, I close the figure in order to move on with the program:
uiwait(menu.FigH)
All of my menu's fields--which include dropdown lists and text edit fields--work 100% as expected (code not shown). However, there is an odd "bug" with the accept/cancel buttons. The buttons do not work when I try to use them via their default location (bottom-right corner of my monitor). They do not even show the blue borderline that typically surrounds them when you hover a mouse over a pushbutton. If I move the figure a couple inches to the left, they suddenly work again. If I move the figure back to its initial location, they no longer work.
It's almost as if there is an invisible object between these buttons and the mouse, but I have no reason to think that any invisible object would be present. I do not use. Any ideas?
  5 Comments
Adam Danz
Adam Danz on 1 Aug 2019
Any way you could attach all necessary files so we can run this and reproduce the problem? We'd need "addDataTypeFields", "addPCAFields", and anything else currently missing.

Sign in to comment.

Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!