'Open current folder in file manager' does nothing - MATLAB R2019b on Kubuntu 19.10

14 views (last 30 days)
Hello, on Kubuntu 19.10 clicking on "Open Current Folder in File Manager" option does nothing in MATLAB R2019b update 2. Running command
system('xdg-open ~')
produces:
>> system ('xdg-open ~')
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by kde-open5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Widgets.so.5: no version information available (required by kde-open5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by kde-open5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by kde-open5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5KIOWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Widgets.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5KIOWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Network.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5KIOWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5KIOWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5KIOWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Xml.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5KIOCore.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5KIOCore.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5KIOCore.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Network.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5KIOCore.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5I18n.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5I18n.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5X11Extras.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5JobWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5JobWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5JobWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5JobWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Widgets.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5JobWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Service.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Service.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Xml.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Service.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Widgets.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Completion.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Completion.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Completion.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Completion.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Svg.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5IconThemes.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5IconThemes.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Widgets.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5IconThemes.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5IconThemes.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5IconThemes.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ConfigWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Widgets.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ConfigWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ConfigWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ConfigWidgets.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Widgets.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5WindowSystem.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5X11Extras.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5WindowSystem.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5WindowSystem.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5WindowSystem.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5WindowSystem.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5WidgetsAddons.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5WidgetsAddons.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5WidgetsAddons.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Widgets.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5WidgetsAddons.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Xml.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ConfigGui.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ConfigGui.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ConfigGui.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ConfigGui.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ConfigCore.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ConfigCore.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libQt5DBus.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libQt5DBus.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libQt5DBus.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Crash.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5X11Extras.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Crash.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Crash.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Crash.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5X11Extras.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5DBusAddons.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5DBusAddons.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5DBusAddons.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5AuthCore.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5AuthCore.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Archive.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Archive.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ItemViews.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Widgets.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ItemViews.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ItemViews.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5ItemViews.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Codecs.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5Codecs.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Gui.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5GuiAddons.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5GuiAddons.so.5)
kde-open5: /usr/local/MATLAB/R2019b/bin/glnxa64/libQt5Core.so.5: no version information available (required by /lib/x86_64-linux-gnu/libKF5GuiAddons.so.5)
kde-open5: symbol lookup error: /lib/x86_64-linux-gnu/libKF5GuiAddons.so.5: undefined symbol: qt_version_tag, version Qt_5.12
ans =
4
However, if I run "xdg-open ~" directly from the system terminal, it can suggessfully open the file manager (dolphin in KDE), so I don't think these Qt libraries are missed in my computer. What is the cause and sollution of this problem?

Answers (2)

S-Jerry
S-Jerry on 16 Jun 2020
Easiest solution would be to use startup.m file for changing LD_LIBRARY_PATH variable on every start of the Matlab (not the most elegant solution but it works).
  1. Create/Modify startup.m file in startup folder of your Matlab (folder can be changed in general preferences)
  2. Locate the path for libQtxxxx.so.5 system libraries (command in terminal: locate libQt5Core.so.5, in my case results in /usr/lib/x86_64-linux-gnu)
  3. Put following line of code in the script and save:
setenv('LD_LIBRARY_PATH', ['/usr/lib/x86_64-linux-gnu:',getenv('LD_LIBRARY_PATH')]);
Command puts the path for your system libraries on the begining of the LD_LIBRARY_PATH (letting the rest of the variable unchanged).
For getting everything back just remove the startup.m file.

Walter Roberson
Walter Roberson on 18 Dec 2019
If you are starting MATLAB from an icon, then it probably is not executing your shell initialization files, and so it is probably not getting some changes to either your PATH or (more likely considering those error messages) LD_LIBRARY_PATH .
Or https://forum.qt.io/topic/74608/why-this-message-libqt5core-so-5-no-version-information-available-is-showed suggests that you might be mixing Qt libraries; MATLAB might be putting its own Qt libraries on the library path (because it needs those) but xdg-open needs the system Qt libraries. In this case, there is a possibility that if you move aside MATLAB's Qt libraries then maybe it would be able to use the system Qt libraries; if you try this be sure to make it easy to restore the Qt libraries in case it doesn't work out.

Tags

Products


Release

R2019b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!