I read that resnet-50 is working with MATALB-17 version onwards. Provide a solution to make resnet-50 work with 2016a ..

3 views (last 30 days)
Minakshi Atre
Minakshi Atre on 23 Apr 2020
Edited: Sai Bhargav Avula on 14 May 2020
I read that resnet-50 is working with MATALB-17 version onwards. Provide a solution to make resnet-50 work with 2016a ..
  1 Comment
John D'Errico
John D'Errico on 12 May 2020
As indicated in the answer. The solution is simple, although perhaps unfortunate for you.
You cannot use a newer toolbox in an old release. Either you upgrade MATLAB to the new release, or you would need to write equivalent capability in the old release. But nobody else will do that for you. And the MathWorks cannot write code to support older releases when they release a new toolbox.
As such, if you really need that capability and cannot write it yourself, then you really need to upgrade your MATLAB release. As I said, this is perhaps unfortunate, but just how things work.

Sign in to comment.

Answers (1)

Sai Bhargav Avula
Sai Bhargav Avula on 12 May 2020
Edited: Sai Bhargav Avula on 14 May 2020
Hi,
ResNet-50 belongs to Deep learning toolbox. Deep learning toolbox is available from MATLAB 2017a. Also ResnNet-50 is made available from MATLAB 2017b. Hence ResNet-50 cannot work with MATLAB 2016a. Kindly update your version to MATLAB 2017b to work with ResNet-50.
Hope this helps!

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!