MATLAB Answers

Matlab Onramp Videos can't be played

18 views (last 30 days)
Eilert on 2 Nov 2020
Edited: Eilert on 4 Nov 2020
I'm having problems viewing the Videos for the Matlab Onramp course.
I'm using Fedora 33 with Firefox 82.0.2 (64-Bit) and Chromium Version 85.0.4183.121 (Entwickler-Build) Fedora Project (64-Bit).
This video is either unavailable or not supported in this browser
Technical details :
The media could not be loaded, either because the server or network failed or because the format is not supported.
If you are using an older browser please try upgrading or installing Flash.
Session ID: 2020-11-02:70608426197cabd5f7d8093c Player ID: videoPlayer
The video is bad or in a format that cannot be played on your browser
Technical details :
The media playback was aborted due to a corruption problem or because the media used features your browser did not support.
Session ID: 2020-11-02:5270239377616d596ffd1e81 Player ID: videoPlayer
I already tried to install the Flashplayer rpm from Adobe, but it failed somehow. It was even not recognized by the Adobe check website.
(Besides, are you really still using Adobe Flash these days?)
I also tried several browser settings and disabling adblockers, to no avail.
Can you give me any hint how I can view these videos (The interactive tests are working) .
Can they be downloaded somewhere, for viewing with an external player.
Kind regards

Answers (3)

Eilert on 3 Nov 2020
Edited: Eilert on 3 Nov 2020
Dear Chris,
except for unsing Windows or Chrome, all browser and system requirements have been checked even those listed on other pages.
popups allowed
javascript enabled
cookies enabled
hardware aceleration disabled
adblockers disabled
Caches cleared before reload
The latest OS and stable browser releases for the OS (Fedora 33) are in use.
Still no video playing possible.
Crosschecked on a Ubuntu 20.04 LTS Linux with Firefox 82.0 using the same standard settings and adblockers enabled works fine.
A second Fedora 33 Firefox 82.0.2 failed.
A third Fedora 33 Firefox 82.0.2 worked. The difference is, this is a multiple upgraded version (initially less than Fedora 28), while the others are fresh installed.
Seems like there's some vital component missing (e.g. special media decoding libraries) and the problem is not related to the browser.
What kind of video codecs are required to play the mathworks videos in a browser that are not part of a standard Fedora 33 installation?
Kind regards
Cris LaPierre
Cris LaPierre on 3 Nov 2020
If it helps, we use Brightcove for videos. You could try their troubleshooting guide as well. Look for the error codes:

Sign in to comment.

Eilert on 4 Nov 2020
Edited: Eilert on 4 Nov 2020
Hello Cris.
I've been on the Brightcove troubleshooting giuide page before. No solutions there for this problem.
The problem has been reported to Brightcove Support.
I added the h264 codec packages yesterday:
sudo dnf install mozilla-openh264.x86_64
Which also installs the generic openh264 package.The situation remained unchanged that day.
Today, the computer was started new, and now at least firefox plays all videos.
Verified this on another system: Reboot is required. (Unless someone knows another way e.g. using some systemd command)
Problem solved for Firefox.
The Problem still remains for Chromium.
Kind Regards

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!