MATLAB Answers

Simulink Pixhawk Support Package System Requirements

6 views (last 30 days)
J Chen
J Chen on 27 Jan 2021
Edited: Daniel_ on 2 Feb 2021
What is the MINIMUM system requirement to generate code from Simulink and download to a Pixhwak in R2020b? Will I be able to just click a button in Simulink to generate and download codes? Do I have to have the UAV and/or embedded coder toolboxes? Mathwoks is very vague about this.

Answers (2)

Ankur Bose
Ankur Bose on 27 Jan 2021
You need below mentioned minimum products to work with UAV Toolbox Support Package for PX4 Autopilots
  • UAV Toolbox
  • MATLAB
  • Simulink
  • MATLAB Coder
  • Simulink Coder
  • Embedded Coder
Recommended Products
  • Stateflow
  • Instrument Control Toolbox
  1 Comment
J Chen
J Chen on 27 Jan 2021
I don't see why the Matlab and Simulink coders are needed. I don't think they are required. I'm not sure about the Embedded coder. The Arduino Support Package doesn't require the Embedded coder. I also don't underatnd why UAV Toolbox is required.

Sign in to comment.


Daniel_
Daniel_ on 2 Feb 2021
Edited: Daniel_ on 2 Feb 2021
I agree with Ankur Bose. You can install: Matlab, Simulnik and UAV Toolbox to start modeling. But if you want to generate a code for a device such as pixhawk 1 or Cube 2.1 then you will get a message that you need Simulink Coder and Matlab Coder. I also have an Embeded coder and generating the correct code on these six elements works nicely. Remember about the seventh element that you must have visible in the add-ons - "UAV Toolbox Support Package for PX4 autopilots" that will appear after finding and installing it from Add-On explorer.
Edit:
Yes, this is also marked below at requires:

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!