MATLAB Answers


Mex line 206 error for everything

Asked by Julia
on 3 Jul 2013
Latest activity Commented on by Richa
on 4 Feb 2014

I am attempting to use mex to compile C++ files in Matlab, but I can't even get that far. I am running R2012b in Ubuntu 12.04.

When I try to use mex, I always get "Error using mex (line 206) Unable to complete successfully." This occurs immediately, even when I run "mex -setup" or "mex -help".

Any ideas what could be causing this and how to fix it?


Log in to comment.


3 Answers

Answer by Guru
on 3 Jul 2013

Without knowing what C++ compiler you are using or C++ files involved, it will be very difficult to say exactly why you are getting the error. The error message itself is very generic and I would suggest that you use some debugging means with mex.

mex -v filename.cpp

will allow you to get a more verbose display and determine exactly what error messages is your compiler giving you.

You also have to make sure you have formatted the files appropriately with the MEX wrapper notation that you can find within the help documentation of mex


Log in to comment.

Answer by Julia
on 3 Jul 2013

Not even that works. Even "mex -v filename.cpp" produces the same error immediately with no more information.

It's not just a matter of the files I'm trying to compile, since I even "mex -help" gives the error.


Ok, this seems more like an issue with your installation. Try the following:

which -all mex
doc mex

For me, I see this full message when I try to run "mex -setup"

No supported SDK or compiler was found on this computer. For a list of supported compilers, see

Error using mex (line 206) Unable to complete successfully.

which does replicate your error. In my case it is because I do not have any supported compilers that mex can work with.

What should I be seeing with "which -all mex"? I get the path to a mex.m file in the location of my installation.

I do not receive any additional information in the error message when I try to run setup. I looked at the compilers, and I do have supported compilers installed, so that's not the issue.

I am running Matlab from the command line, though, and this did appear there:

MATLAB was unable to run the matlab_helper executable, which the ! and
unix() commands require.  You may have an incomplete installation or
permission problems with /Network/Servers/husain/Volumes/husain/jebert/matlab_r2012b/bin/glnxa64/matlab_helper

It was a permissions/execution issue. Fixed!

Ok, glad that you were able to resolve the problem!

Log in to comment.

Answer by Richa
on 29 Jan 2014

Hi Julia,

I am facing the same problem. Can you please guide me how to fix it? I am getting error when even i run the command mex -setup.

Thanks and Regards, Richa Garg


Are you getting down to the point it says "or permission problems" ? If you are then

!chmod +rx FILE

where FILE is the file name given in the message. You might need to have someone with administrative access to do it (might require "sudo")

Thanks a lot! :) It was a permission issue.

Log in to comment.

Discover MakerZone

MATLAB and Simulink resources for Arduino, LEGO, and Raspberry Pi

Learn more

Discover what MATLAB® can do for your career.

Opportunities for recent engineering grads.

Apply Today

MATLAB Academy

New to MATLAB?

Learn MATLAB today!