How can I make obsolete block work in new version Simulink?

8 views (last 30 days)
I have a NI PCI-6229,I want to make it working in MATLAB 2018b,but,MATLAB 2018b show 'Obsolete block'.
  2 Comments
zhisheng Dong
zhisheng Dong on 15 Jun 2021
The block PCI-6229 DI PCI-6229 DA PCI-6229 AD. The last version is MATLAB 2017a.
Thanks

Sign in to comment.

Accepted Answer

Dimitri MANKOV
Dimitri MANKOV on 22 Jun 2021
Edited: Dimitri MANKOV on 22 Jun 2021
Hi Zhisheng,
That's correct: support for custom/third-party target hardware has been removed from Simulink Real-Time in R2018a. Starting from that release, only Speedgoat target machines and I/O modules are supported. Speedgoat offers modules with similar functionality fully compatible with the latest MATLAB releases.
For more information, have a look at www.speedgoat.com and at the Release Notes for Simulink Real-Time.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!