Clear Filters
Clear Filters

Matlab R2014b with OS X Yosemite Issue

2 views (last 30 days)
I am trying to use the plane program and keep getting the following error when I run it:
Error using figure
There is no numb property on the Figure class.
Error in pplane8 (line 398)
ppset = figure('name','pplane8 Setup','numb','off',...
Any ideas on what I should do? I've tried two separate Macs on Yosemite and it does the same thing.
  13 Comments
Walter Roberson
Walter Roberson on 19 May 2015
I looked at the code and saw that it was trying to create a string containing the figure number. I looked at the documentation for Figure Properties and saw that there is now a Number property that returns the figure number. So get() of the Number is what was needed. The rest of the time was spent searching through the code to be sure that the problem did not occur elsewhere.
Samuel Dupree
Samuel Dupree on 20 May 2015
Walter,
Thank you for the explanation. I gratefully appreciate it. This clears things up for me.
Again, thanks.
Sam Dupree.

Sign in to comment.

Accepted Answer

Geoff Hayes
Geoff Hayes on 21 Nov 2014
Austin - try changing the numb to the full property name NumberTitle. So line 398 of pplane8 would become
ppset = figure('name','pplane8 Setup','NumberTitle','off',...
'tag','pplane8','visible','off',...
'UserData',ud);
Note the change also from user to UserData. See figure window properties for more details.
  7 Comments
Geoff Hayes
Geoff Hayes on 9 Jul 2015
Try typing just
get(dud.axes)
to see which properties are available. If you don't see something for 'user' then you may have to use UserData.
Daniel Sierra
Daniel Sierra on 9 Jul 2015
Thanks Geoff it worked! i also had to make a few changes that i haven't read from this forum but so far it seems to work just fine!

Sign in to comment.

More Answers (2)

Hugh Harvey
Hugh Harvey on 17 Feb 2017
Hi, I have gone through and made all these changes to Pplane - Please see link for updated version: http://uk.mathworks.com/matlabcentral/fileexchange/61636-pplane

Jakob
Jakob on 21 Jun 2016
Very good work everyone. The pplane-tool is extremely useful! Great you made it work again in newer Matlab!! Cannot give enough kudos ;-)

Categories

Find more on Introduction to Installation and Licensing in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!