Clear Filters
Clear Filters

Live Script not working - Fedora 36

3 views (last 30 days)
VC
VC on 10 Nov 2022
Answered: Gowthami on 25 Nov 2022
Hi. Thanks in advance.
I am unable to create a new live script or open a .mlx file. The following error is shown when I try to do so - "Unable to open this file in the current system configuration.".
Further, the documentation does not load. It takes me to a blank 'Help' window.
I have tried the following with no success -
  1. Checked for libgconf-2-4, which is now part of GConf2. This is already installed.
  2. Tried to find broken symlinks in '/usr/local/MATLAB/sys/jxbrowser-chromium/glnxa64/chromium/'. But, there is no 'jxbrowser-chromium' directory. Similarly there is no 'HtmlPanel' directory in '$HOME/.matlab/2022b/', which was suggested as an alternative location for the said broken symlinks.
  3. Tried to find missing dependencies. But how do I do that since this can be found in the above missing directory.
Please help. I wrote my code in .mlx and I need to submit it for an assignment this weekend.
I have MATLAB R2022b installed on Fedora 36 (Gnome 42).
The solutions from the following answers do not work for me -

Answers (1)

Gowthami
Gowthami on 25 Nov 2022
Hello VC,
It is my understanding that you are unable to create a new live script or open a '.mlx' file in Live Script.
Please try the workaround mentioned in the below MATLAB Answers link to see if the issue is resolved-https://www.mathworks.com/matlabcentral/answers/1815470-matlab-live-editor-unable-to-open-this-file-in-the-current-system-configuration

Categories

Find more on Introduction to Installation and Licensing in Help Center and File Exchange

Products


Release

R2022b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!