Clear Filters
Clear Filters

SIL testing Issue with simulink

30 views (last 30 days)
Rahul
Rahul on 18 Apr 2023
Answered: Gowthami on 24 Apr 2023
I am trying to do SIL testing for my Simulink model. Right now I am testing only one subsystem. I have followed all the steps instructed on Mathwork websites/videos. When the code is being built to perform SIL i get the following error " Fatal error C1083: Cannot open include file: 'stddef.h': No such file in directory.
Ive also tried SIL on other models of mine and I get a similar error, it's always some header file missing. In one of my models Cannot open include file: 'string.h': No such file in directory.
The model I tried was a simple PID controller.
On another note, If i try to generate code using embedded coder I have no Issues.
although my main aim is SIL testing.
Any help to resolve this would be greatly appreciated.

Accepted Answer

Gowthami
Gowthami on 24 Apr 2023
Hello Rahul,
This error message appears to be caused by an issue with the installation of Microsoft Visual Studio 2017, which is being used to compile the C++ code for simulating the model in Accelerator mode.
Two different methods to resolve this error message are to:
1. Switch to the 'MinGW' compiler using the following command -
mex -setup
Check that your Simulink model also shows MinGW (Model Configuration Parameters > Code Generation > Toolchain > Underneath "Automatically locate an installed toolchain").
2. Try fully uninstalling and reinstalling Visual Studio 2017.

More Answers (0)

Tags

Products


Release

R2022b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!