cmake: undefined symbol: uv_fs_get_system_error

56 views (last 30 days)
Luis on 26 Feb 2024
Answered: Nate Rolfes on 29 Feb 2024
After adding the path to cmake (ubuntu 22.04, whereis cmake) into the 'Set Path' folder, I try:
>> [status,cmdout] = system('cmake --version')
status =
cmdout =
'cmake: symbol lookup error: cmake: undefined symbol: uv_fs_get_system_error '
I run 'cmake --version' on terminal and it works fine. I have not found any other thread with uv_fs_get_system_error on cmake. Is this a matlab error or a cmake error? I have tried other commands using system() with no issues. Any help is greatly appreciated.
  1 Comment
Nate Rolfes
Nate Rolfes on 29 Feb 2024
Edited: Nate Rolfes on 29 Feb 2024
I"m also getting the same error with 22.04 and Matlab R2023b

Sign in to comment.

Answers (1)

Nate Rolfes
Nate Rolfes on 29 Feb 2024
i think i figured it out. had an old version of Cmake (v3.21 or something) and updating to latest (v3.25, v3.28 both worked for me). fixes the issue. at the linux terminal:
sudo apt remove cmake
sudo snap install cmake --classic
set me up with v3.28.3 and then running the
system('cmake --version')
command returns successfully


Find more on Functions in Help Center and File Exchange




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!