mex -setup c++ not working

6 views (last 30 days)
Wenjuan on 23 Feb 2017
Good afternoon. I have installed Microsoft SDK7.1 and .NET framework 4.0. However, Matlab seems can't find it. and when I run mex -setup c++, it shows error message below:
Error using mex No supported compiler or SDK was found. For options, visit
Could anyone let me know what may cause this error? and how to solve it?
The matlab I am using is Matlab 16a, window 7 system.
Muhammed Ali Erbir
Muhammed Ali Erbir on 6 Dec 2018
SDK is not enough. you have to install visual studio (at least community version)
while installing you have to select "C++ desktop app development" option
compiler for matlab.PNG

Sign in to comment.

Answers (1)

Jan on 23 Feb 2017
Edited: Jan on 23 Feb 2017
There are a lot of concerning threads in the forum (currently 792 - horryfying!):
Did you select the 64-bit compilers during the installation or are you using a 32 bit Matlab? For me it worked to install the SDK after Matlab.


Find more on Troubleshooting in MATLAB Compiler SDK in Help Center and File Exchange



Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!