Issue with

476 views (last 30 days)
Luis Martins
Luis Martins on 14 Mar 2017
Commented: Lukas Heyn on 14 Nov 2022 at 20:45
Dear all,
I'm running matlab r2017a on a linux Fedora 25 machine and when I tried to call an external program that required the graphical interface I got the following error.
OpenSees: /usr/local/MATLAB/R2017a/sys/os/glnxa64/ version `GLIBCXX_3.4.21' not found (required by OpenSees)
OpenSees: /usr/local/MATLAB/R2017a/sys/os/glnxa64/ version `CXXABI_1.3.9' not found (required by OpenSees)
When I used a built-in function of matlab I also got a similar error
Error using waitbar (line 111) Improper arguments for waitbar.
Error in selectRecords (line 8) h = waitbar(0,'Processing records');
Caused by: Error using axes Can't load '/usr/local/MATLAB/R2017a/bin/glnxa64/': /usr/local/MATLAB/R2017a/bin/glnxa64/../../sys/os/glnxa64/ version `CXXABI_1.3.9' not found (required by /lib64/
I checked using the terminal and I've got the latest version of that library installed
sudo dnf install libstdc++ Last metadata expiration check: 0:56:33 ago on Tue Mar 14 13:05:15 2017.Package libstdc++-6.3.1-1.fc25.x86_64 is already installed, skipping.Package libstdc++-6.3.1-1.fc25.i686 is already installed, skipping.Dependencies resolved.Nothing to do.Complete!
Could you please provide some guidance on how to solve this issue?
cheers L.M.
  1 Comment
Nader Fathy
Nader Fathy on 9 Feb 2021
I had a similar issue using CentOS 7 and the following solved the issue for me:
yum install compat-libstdc++-33.x86_64
Hope this helps!
Kindest Regards,
Nader Fathy

Sign in to comment.

Accepted Answer

Archita P
Archita P on 20 Mar 2017
Edited: Archita P on 20 Mar 2017
This issue might be due to an incompatibility between the libstdc++ shipped with MATLAB and the libstdc++ shipped with the system that the other application was linked against.
"CXXABI_1.3.9 not found" error message indicates that the library that is included with MATLAB is missing ABI versions the system needs to draw graphical content.
This is caused because the version of this particular library packaged with MATLAB is older than the versions that come with newer Linux operating systems, which causes compatibility issues.
You can try the following workarounds: 1. Renaming the library file so that MATLAB cannot find it and is forced to use the system's version of the library. This file is located in matlabroot/sys/os/glnxa64 . Renaming it to should suffice. (where "matlabroot" is root installation directory of MATLAB)
2. Forcing MATLAB to load the system version by setting the $LD_PRELOAD environment variable to the newer version of libstdc++.
Also, since you are trying to call an external program from MATLAB, this may be a third party issue. But, you can try setting the library paths correctly in 'LD_LIBRARY_PATH' system variable.
Lukas Heyn
Lukas Heyn on 14 Nov 2022 at 20:45
solved the problem for me in Matlab R2022b and Ubuntu 22.04, too

Sign in to comment.

More Answers (3)

John Smith
John Smith on 12 Jul 2019
You need to be careful with making sure you load the correct libstdc++6.
I use it to load "brainstorm", an EEG analysis program that requires the runtime Matlab library.
On Fedora 30, I solved it just as follows:
LD_PRELOAD="/lib64/" path_and_name_of_programme_here
Also, note that you can check whether CXXABI_1.3.9 is included simply as follows:
strings /lib64/ | grep CXXABI
You should then see that in the text part of that library. If it shows up, it means it should work.

S.Y Wang
S.Y Wang on 9 Dec 2017
"import matlab.engine" should at the first line of the script.
BRSC User on 9 Apr 2020
See suggested solution above.

Sign in to comment.

Luis Rosety
Luis Rosety on 16 May 2022
I had the same problem with Kubuntu 22.05 and the solution was what was posted in
  1. Star Matlab with
matlab -softwareopengl
2. Once in Matlab, run the command

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!