Clear Filters
Clear Filters

Why do I receive a "Method not implemented" error when using Git source control?

2 views (last 30 days)
Yesterday I set tried to set up git source control for a directory. I clicked on "Source Control" -> "Manage Files", and then changed the Source control integration to "Git" in the source control UI. However, when I try to validate the remote repository I get the error message
"Unable to validate the specified path with the following git error: Method not implemented."
I later tried editing a file under pre-existing Git source control. I was able to commit changes, but when I tried to push them to the remote directory, I again received the error: "Method not implemented". The pull and fetch commands also created the same error.
I was able to push changes to this file and set up new source control as recently as two days ago. Why this error is occurring?
(I'm using MATLAB 2018b on macOS High Sierra. I also tested everything on older versions, MATLAB 2018a and 2017a, and they also generate the error).
Kojiro Saito
Kojiro Saito on 11 Oct 2018
Do you get the same error when pushing or pulling by other Git clients software (GitHub Desktop etc)?
Jonathan King
Jonathan King on 12 Oct 2018
No, it's only the MATLAB interface. I'm able to push/pull/clone from both GitHub Desktop and Terminal (with command line git).
I can also make commits from the MATLAB interface, and then push those commits from GitHub Desktop. I'm currently using that as a workaround to the "Method not implemented" error, but I'd still prefer to fix the Matlab interface...

Sign in to comment.

Answers (0)


Find more on Source Control Integration in Help Center and File Exchange




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!