MATLAB Answers

Connector failing to run

6 views (last 30 days)
Peter Vassallo
Peter Vassallo on 10 Sep 2012
After successfully installing the MATLAB connector, typing connector on returns the following error:
Undefined function 'connector' for input arguments of type 'char'.
I tried installing the connector again, which was apparently done successfully but again it doesn't seem to be working.

  0 Comments

Sign in to comment.

Answers (2)

Pradeep
Pradeep on 17 Sep 2012
Hi Peter,
Although the installation adds the connector folder to your path, it's possible that this might not have happened. After you've installed the connector, what does
>> which -all connector
return?
If you're on Windows, try opening MATLAB as an administrator and then install the connector.

  2 Comments

Caitlyn
Caitlyn on 22 Oct 2012
I'm having the same problem. When I enter >>which -all connector Matlab returns 'connector' not found. I did install the connector. Any ideas on how to fix this?
Arturo
Arturo on 18 May 2013
I've exactly the same problem and can't fix it

Sign in to comment.


Paul
Paul on 1 Sep 2013
I was having a similar issue. I had unzipped the subfolders (connector-1.2 and connector-2.0) when I first tried installing it. When I ran it again with the subfolders zipped, it worked.
Since I am running Windows 7, I also made sure to run Matlab as an administrator by right-clicking program icon in the start menu and selecting the "Run as administrator" option.

  0 Comments

Sign in to comment.