File Exchange

image thumbnail

Simulink Support Package for Apple iOS Devices

Run models on Apple iOS devices.

158 Downloads

Updated 11 Sep 2019

Editor's Note:

This support package is currently unable to download third-party software for MATLAB R2017a and earlier versions. For details and workaround, see this Bug Report.

MATLAB R2017b and later versions are unaffected.

Simulink® Support Package for Apple iOS Devices enables you to create and run Simulink models on the iPhone, iPod, and iPad. The support package includes a library of Simulink blocks for:
• Sensors
• Audio capture and playback
• Camera input and video display
• UI widgets
• Network interface

This support package is functional for R2015a and beyond.

Comments and Ratings (13)

ulas

With xcode10.3 and MATLAB r2019a, the app crashes just after launch.

L.J.

Yay! Worked without any problems. Please visit my shared folder to see the data I collected from my iPhone.
https://drive.matlab.com/sharing/385dcbe2-e913-4c9e-b522-3841ef75404f Search for my blog "MATLAB & iOS" www.bits4bots.shop or www.bits4bots.com

I can't get it to work. The app is generated on the phone but after launch it crashes :o(

It doesn't work with iOS 12 and Xcode 10

please add support to windows PC and IOS also :-)

@Alma: I am afraid that there is no single cause that can result in the error message you described. If you contact technical support and talk to the installation team:

https://www.mathworks.com/support/contact_us.html

they can go through the support package installation process with you and narrow down on the cause of the error.

There's an error that occurs during the installation, it says t"There was a problem installing the third-party software. To resolve this issue, contact Technical Support". Do you know why this happend? I have MacBook and IPhone.
Thanks for your comments

Description not clear as to what hardware configurations this can run on... From what I understand you must have a macOS (Macbook) and an iOS device (iPhone/iPad), so those of us who have a Windows PC and iPhone cannot use this add on.

saras

@Dennis: This support package works with macOS (previously named OS X) and not with Windows.

Every time I try to install the package, the following message aperes:
"The support package is not compatible with your version of MATLAB or operating system!"

I'm using Windows 10 (64) and Matlab R2016b, where is the Problem ?

It's a great package and easy to use. I implemented some audio demos using it, and I don't need to configure much on iOS to use this package. It would be better if I can control the layout of the button/sliders on the screen. Looking forward to it!

@MartinF: Thanks for the info.

URL has been fixed.

Also, please try refreshing your browser or clearing your browser cache to get the updated/correct documentation. There was an early doc issue, but it has been resolved.

MATLAB Release Compatibility
Created with R2015a
Compatible with R2015a to R2019b
Platform Compatibility
Windows macOS Linux