Discover MakerZone

MATLAB and Simulink resources for Arduino, LEGO, and Raspberry Pi

Learn more

Discover what MATLAB® can do for your career.

Opportunities for recent engineering grads.

Apply Today

CCS 5.1 integration: when and how

Asked by Martin Dendaluce on 6 Jan 2012
Latest activity Commented on by Puneeth Kumar Srikanta Murthy on 2 Nov 2014

Hello,

Since it was announced that Mathworks wouldn’t provide the same integration functionalities for TI’s Code Composer Studio v4 as it does for CCSv3.3 and it would skip to the next version, I’ve been waiting for CCSv5 to finally appear, which took longer than expected.

Now that this is out for a while, I couldn’t find any references to when this will be implemented and in which version it will occur. Does anyone have any clue about this? I’d really prefer not having to downgrade to the outdated V3.3, but a part of my project has been in standby for too long already.

Thanks!

Martin

0 Comments

Martin Dendaluce

9 Answers

Answer by Antonin on 12 Jan 2012
Accepted answer

Martin,

You can use CCS v5.1 today with Matlab via the xmakeilesetup infrastructure provided for CCSv4.

To do so, follow these instructions:

  • Type xmakefilesetup at the Matlab command prompt. A GUI opens.
  • Keep the "Template" as "gmake", uncheck "Display operational conifgurations only", then select "ti_c000_ccsv4" for the Configuration.
  • Click Apply on the XMakefile GUI, if you haven't used this tool before, a GUI will ask to browse to you CCS v4 installation folder. Use this tool to point to your CCS v5.1 installation folder (i.e.: C:\TI\ccsv5).
  • If you have previously used this tool with CCSv4 a "Tool Directories" tab should be present below, select that tab and copy your CCS v5.1 installation paths in the edit boxes, i.e:
  1. CCS Installation: C:\TI\ccsv5
  2. Code geeneration Tools: C:\TI\ccsv5\tools\compiler\c2000
  3. Code geeneration Tools: C:\TI\bios_6_32_05_54
  • Click "Apply" on the GUI (don't close it).
  • Click on the "New" button next to "Configurations", the tool will offer to chose a name like "ticcs_c2000_ccsv4_clone", let's rename it "ticcs_c2000_ccsv5_based_on_v4", click "OK".
  • All tabs are now editable, you have to update "Compiler", "Linker" and "Archiver". Make sure that the paths are pointing to your CCS v5.1 installation folders, i.e.:
  1. Under Compiler, the compiler section should poiint to something like : C:\TI\ccsv5\tools\compiler\c2000\bin\cl2000
  2. Under Compiler, the arguments section should poiint to something like : -I"C:\TI\ccsv5\tools\compiler\C2000\include" -fr"[|||MW_XMK_DERIVED_PATH_REF|||]"
  3. Under Linker, the Linker section should poiint to something like : C:\TI\ccsv5\tools\compiler\C2000\bin\cl2000
  4. Under Archiver, the Archiver section should poiint to something like : C:\TI\ccsv5\tools\compiler\C2000\bin\ar2000
  • Click "OK" on the GUI to save your changes and close it.

You can now use the models you have created for CCSv3.3.

  • On your model or on a c2000 demo, double click on the "Target Preferences" block.
  • On the "IDE/Tool Chain" drop down, select "Texas Instruments Code Composer Studio v4 (makefile generation only)". Make sure that you save your target settings first as this will erase the existing configuration.
  • Select the apropiate board and processor. Restore your settings.

You are now ready to generate code using CCS v5.1. This approach will use a makefile based approach to compile and link the code using the CCS v5.1 command like tools. Once these steps are completed you can grab the generated *.out file in the code generation folder and download it on the target using CCS v5.1.

Even though this workaround is based on the CCS v4 support, you don't need to have it installed on your machine. This has been succesfully tested with Matlab R2011b and the pre-release of Matlab R2012a. It should also work with earlier versions of the xmakefilesetup tool.

I hope it helps,

Good luck,

Antonin.

5 Comments

Karuna Mudliyar on 21 Sep 2013

I got it.... The problem was i used 2012b it doesnt had embedded coder in it.. Now I m with 2011b. problem solved..

monica on 21 Jan 2014

we too got the same problem while dealing with 2012a..can u please help us to solve the same problem with 2012a..

Hello Antonio,

With Matlab 2014, I am getting the following error when I try to run the xmakefilesetup command. I have attached the screen shot.

Is it an issue with Matlab 2014. Please let me know.

Thank you!

Puneeth

Antonin
Answer by Martin Dendaluce on 14 Jan 2012

Thanks a lot for you complete and precise answer! I had planned to try such an aproach after making work v4 first, but with your steps I managed to directly configure it for v5. It seems to generate code succesfully, so I assume this part of the configuration is fine now, although I still didn't manage (neither had the chance to spend enough time with it) to make the CCS part work and execute the code on target, but that's another issue.

Anyway: sadly this is only a part of the integration possible with v3.3 where full debug integration is provided. Any clue if we will be able to enjoy this in v2012a??

0 Comments

Martin Dendaluce
Answer by Recep on 22 Jun 2012

I applied these steps and configured matlab for ccs v5, that explanation was very brief and thanks for it but unfortunately I couldn't make it work, when I try a command like ticcs, checkenvsetup or ccsboardinfo, I'm getting following error message, do you have a suggestion for it?

??? Cannot start CCS application (COM error code: 0x80040154). Verify that your CCS software is installed and configured properly.

here my post explaining my problem http://www.mathworks.com/matlabcentral/newsreader/view_thread/321253#880782

1 Comment

Antonin on 16 Jul 2012

The commands ticcs, ccsboardinfo will only work with ccs V3.3 You can run checkenvsetup but make sure you mention ccsv4.

i.e. checkEnvSetup('ccsv4','f28335','check')

Recep
Answer by Srikanth on 17 Nov 2012

This is a very good workaround! However, though the compilation happens flawlessly, the makefile does not get built due to a fatal error whcih reads:

[MW_c6xxx_bsl.c] ".\MW_c6xxx_csl.h", line 3: fatal error: could not open source file "csl_edma.h"

I tried to dig through the literature and found that this error appears because of the unavailability of CSL (Chipset Libraries) which were discontinued in ccsv4 and v5. I hence downloaded the CSL library files from TI website and pointed the CSL Library section in xmakefilesetup utility (Step-3 in the above) to the appropriate directory. This doesnt solve the problem. Apparently one needs to add the appropriate CSL Library (in my case c6713.lib) during the link stage of the Build process. I dont know at which stage does MATLAB link the CSL library and the way in which I can direct it to do the same. I'm pretty sure that I need to work around with some settings in Xmakefile GUI but I don't know which ones. Pls. take note of the problem and let me know the solution if possible. Very Urgent!

PS:I am using MATLAB r2012a and CCSv5.2.1

3 Comments

Antonin on 6 Dec 2012

For TI C6000 processors, make sure you start from ticcs_c6000_v4 configuration.

On the tools directory tab there should be a "Chip Support Library (CSL)" path that you can provide.

The 6713 CSL can be downloaded at:

http://c6000.spectrumdigital.com/dsk6713/ http://c6000.spectrumdigital.com/dsk6713/V2/files/DSK6713.zip

Download the zip, install it on your system and fill the CSL edit box with the installation path.

(i.e. C:\ti\ccsv5\DSK6713)

This should do the trick. I hope it helps,

Antonin.

Srikanth on 8 Dec 2012

Thanks Antonion. I figured it out and this error seems to be evaded now. However, I am facing a new issue now. The build process goes just fine until the makefile is created. When, MATLAB starts building the makefile, it stops with a weird error-

".\MW_c6xxx_csl.h", line 22: fatal error: could not open source file "untitledcfg.h"

I tried everything I could, right from installing older versions of Code Generation tools, DSP/BIOS from TI supported by MATLAB to setting appropriate environmental variables. Yet, I get the same error at the same stage. There is a similar post related to CCSv3.3 in

http://www.mathworks.in/matlabcentral/newsreader/view_thread/277160

but I dont seem to comprehend the solution posted there. I highly appreciate your help with this issue.

Regards,

Srikanth.

Srikanth
Answer by Gurudev on 10 Dec 2012

I had a hard time getting Matlab and Simulink to work with CCS and to understand the difference in support between v3.3 and v4/v5. There is one good video that helped me start. I found it a bit long but it has all the steps needed, from installation to generating code for a simple Simulink model: It works for CCSv3.3 which is older but has automatic download and run from Matlab

http://youtu.be/kiVOA5Js7Ag

The same video exists for CCSv4/5: http://youtu.be/7ed1NLD817s

Just adding my 2 cents to the story, I hope it helps.

2 Comments

Srikanth on 12 Dec 2012

I guess this video is by Antonion (provider of this answer) himself!

Antonin on 15 Jan 2013

New and better quality links to these videos:

CCSv3.3: http://youtu.be/Pcx-VGU1MIM

CCSv4/v5: http://youtu.be/AY4GzMLl30A

Gurudev
Answer by Martin Dendaluce on 16 Feb 2013

Sadly I just saw most of the answers and the videos, which seem quite interesting... thanks!

Luckily I got to work the .out loading some time ago and it seems to be a good solution.

Still, I'll have a llok at your videos, I'm sure I'll learn something with them :-)

Regards!

Martin

0 Comments

Martin Dendaluce
Answer by Tausif on 27 Mar 2013

Hey am running through with the same problem. I can generate the .out file and load and run it in CCSV5 but I want now loop it back to another input pin and observe it in simulink scope. Run it in like PIL. How do I do this?

0 Comments

Tausif
Answer by Gaurav Pipersaniya on 17 May 2013

hey i am using matlab 2012 so which ccs version should i download for code generation from simulink which making any changes.plz help

0 Comments

Gaurav Pipersaniya
Answer by Kalpesh on 18 Oct 2013
  • _ Please help us about this error. I am generating code for OMAPL138 using Simulink8.1 for CCSV5 using this method. _ *

The call to idelink_ert_make_rtw_hook, during the exit hook generated the following error: Error while building the project. The build process will terminate as a result. Caused by: Error while building the project. The build failed with the following message: "C:/ti/ccsv5/tools/compiler/c6000_7.4.2/bin/cl6x" -I"C:/Program Files/MATLAB/R2013a/toolbox/idelink/extensions/ticcs/inc" -I"C:/Users/user8/Documents/MATLAB/untitled_ticcs" -I"C:/Users/user8/Documents/MATLAB" -I"C:/Program Files/MATLAB/R2013a/extern/include" -I"C:/Program Files/MATLAB/R2013a/simulink/include" -I"C:/Program Files/MATLAB/R2013a/rtw/c/src" -I"C:/Program Files/MATLAB/R2013a/rtw/c/src/ext_mode/common" -I"C:/Program Files/MATLAB/R2013a/rtw/c/ert" -D"CHIP_OMAPL138" -D"__TICCSC__" -D"RT" -D"USE_RTMODEL" -mv6400+ -D"MODEL=untitled" -D"NUMST=1" -D"NCSTATES=0" -D"HAVESTDIO=" -D"ONESTEPFCN=1" -D"TERMFCN=1" -D"MAT_FILE=0" -D"MULTI_INSTANCE_CODE=0" -D"INTEGER_CODE=0" -D"MT=0" -D"CLASSIC_INTERFACE=0" -D"TID01EQ=0" -I"C:/ti/ccsv5/tools/compiler/c6000_7.4.2/include" -I"C:/ti/bios_6_35_01_29/include" -fr"./derived/" ./MW_c6xxx_csl.c ./untitled.c ./untitled_data.c ./untitled_main.c [MW_c6xxx_csl.c] ".\MW_c6xxx_csl.h", line 20: fatal error: could not open source file "untitledcfg.h" 1 fatal error detected in the compilation of "./MW_c6xxx_csl.c". Compilation terminated. >> Compilation failure gmake: * [derived/MW_c6xxx_csl.obj] Error 1

0 Comments

Kalpesh

Contact us