MATLAB Answers

Curve fitting tool does not show main plot in Matlab 2013b

23 views (last 30 days)
Laurent
Laurent on 19 Nov 2013
Edited: Julia on 9 Apr 2014
Dear all,
When I use the Curve Fitting Tool in Matlab 2013b on MacOS X it does not show me the 'Main Plot' after fitting a curve. The main plot normally shows the input data and the curve which was fitted to the data. In older Matlab versions (like 2012a) everything worked fine.
In the Command Window the following error is shown:
Exception in thread "AWT-EventQueue-0" java.lang.NoSuchMethodError: javax.media.opengl.GLCapabilities.<init>(Ljavax/media/opengl/GLProfile;)V
at com.mathworks.hg.peer.JavaSceneServerPeer.getCaps(JavaSceneServerPeer.java:125)
at com.mathworks.hg.peer.JavaSceneServerPeer.doCreateCanvas(JavaSceneServerPeer.java:942)
at com.mathworks.hg.peer.JavaSceneServerPeer.access$200(JavaSceneServerPeer.java:44)
at com.mathworks.hg.peer.JavaSceneServerPeer$2.run(JavaSceneServerPeer.java:914)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:721)
at java.awt.EventQueue.access$200(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:682)
at java.awt.EventQueue$3.run(EventQueue.java:680)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:691)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Does anyone know a solution for this problem?
Thanks.
(Sorry for the formatting of the error message...)
  9 Comments
Julia
Julia on 9 Apr 2014
Dear all, after changing the Java version and/or running matlab as an administrator didn't help, I decided to contact the matlab support. They send me a java-related patch which resolved the issue. Therefore, I would suggest that if any of you is experiencing the same problem, contact support.
Have a good day, Julia

Sign in to comment.

Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!