MATLAB Answers

problem with real time udp in xPC target 5.5 when using the Intel-Gigabit ethernet adapter

3 views (last 30 days)
fatima
fatima on 21 Nov 2013
Commented: Xikai on 13 Oct 2017
hello! I have two network adapters in my xPC target which both of them are Intel-Gigabit(82540EM). when I try to boot the system and load my model on target machine, I have no problem. but when I run the model, It stopped in running mode and the connection between host and target failed. (TCP/IP connection disconnected). I check the setting of the network configuration and set it's parameters as follows: IP address : 192.168.4.105 subnet Mask : 255.255.255.0 Gateway : 192.168.4.1 Ethenet driver : Intel Gigabit PCI bus: 2 Slot: 3 when I changed the secondary adapter card and useed a 8255x card, program was completely executed and had no problem. but I need to use Intel-Gigabit as a secondary adapter. Is there any way to configure the system(software and hardware) where I will be able to use an Intel-Gigabit as a secondary card in real time udp applications? Is it possible to exist any inconsistency between my network adapters and other hardwares in my system(like mother board, ram ...)? Can you prefer any hardware setup for optimum performance in the applications that real-time udp is needed? best regards.

Answers (1)

Rajiv Ghosh-Roy
Rajiv Ghosh-Roy on 6 Dec 2013
I think both your host-target communication and real-time UDP are trying to use the same card. For diagnostics, I would try the following steps:
  • Make sure the bus and slot displayed at boot time (which is the one used by the host-target communication) is different from the one you specify in your model for real-time UDP.
  • You may have to experiment with disconnecting/reconnecting Ethernet cables and seeing which functionality (host/target or real-time UDP) still works to identify the cards. Bus 2, Slot 3 or similar tells us the identification of the card on the bus, but not the physical location.

  2 Comments

fatima
fatima on 6 Dec 2013
When I built my program, it was uploaded on target computer completely an didn't have any problem, I checked the host-target Ethernet card's bus and slot and assured that it was different from the host-target card. When I commanded to start the program, It was stopped in 'running' mode and the target computer disconnected from the host computer, I checked all the connections, but there was no problem in cables or other hardware. I tried to reconnect the host and target but I didn't successful. finally I was compelled to restart the target computer. I've changed my cards and other hardware to remove any incompatibility in my system but I haven't successful till now.

Sign in to comment.

Sign in to answer this question.