MATLAB Answers

Suddenly neural network toolbox doesn't work anymore

17 views (last 30 days)
Gechas on 17 Jun 2014
Answered: software on 8 Jul 2019
I worked with the neural network toolbox until yesterday when suddenly I got a error message:
At first I thougt that somehow the data I feed into the neural network got corrupted. But after checking this I could rule it out as I cause. To make sure it is not the data I tried the sample data that comes with MATLAB and I get the same error message with the sample data.
If I try to call patternnet(10) in the command window I get the following error message:
>> net=patternnet(10)
Default value is not a member of type "nntype.performance_fcn".
Error using nnetParamInfo (line 28)
Reference to non-existent field 'net_read_only'.
Error in patternnet>get_info (line 85)
info = nnfcnNetwork(mfilename,'Pattern Recognition Neural Network',fcnversion, ...
Error in patternnet (line 41)
if isempty(INFO), INFO = get_info; end
I have R2013b 64-bit. Does anybody have an idea what could be the reason that suddenly the neural network toolbox doesn't work anymore? I would very much appreciate your help.


Sign in to comment.

Answers (2)

Tunan on 4 Jul 2014
I have the same problem. All of a sudden, Matlab NN toolbox doesn't work any more. It was fine in May.
When I was trying the nprtool and using the sample data, it doesn't work.
Anybody know what's happening? There is no source code since we are using the GUI.


Show 3 older comments
John Malik
John Malik on 18 Nov 2016
This worked for me. I had another MATLAB file called mse.m in my path that was distracting the Toolbox, so I removed it.
Nick Durkee
Nick Durkee on 21 Mar 2017
Thanks, mse.m was troubling me too. A utility folder for another project was overshadowing MATLAB's libraries.
Ali Mutlu
Ali Mutlu on 5 Dec 2017
Thanks a lot John Malik, the problem is resolved!

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!