Info

This question is closed. Reopen it to edit or answer.

I cannot install Matlab 2014a on OS X Yosemite 10.10 public beta

3 views (last 30 days)
When I install Matlab 2014a on OS X Yosemite 10.10 public beta, it shows Matlab logo and then it says: “Install MATLAB quit unexpectedly.”
1.I install JDK/JRE before I try to install Matlab, but it still not works.
2.I changed ProductVersion in SystemVersion.plist to 10.90 or 10.9 according to this video https://www.youtube.com/watch?v=GoQnzIyOkB0 before I install Matlab, but it also still not works.
What can I do? Thank you!
  1 Comment
xiaochuan
xiaochuan on 23 Oct 2014
Hi Hongbo, I tried the patch you posted and my R2014a works in 10.10 but it's blurry. Do you have any idea how to fix it? Thanks!

Accepted Answer

Hongbo Miao
Hongbo Miao on 1 Aug 2014
Edited: Hongbo Miao on 17 Oct 2014
ATTENTION:
______________________________________________________
1. First install OS X 10.9 in Parallels Desktop.
(At first I want to install Matlab in this virtual system. But I find when I install Matlab, I meet a same problem just like in OS X 10.10.)
2. Now you can install Matlab in real system (Make sure your virtual system run when you install Matlab in real system. If virtual system stops, you cannot install Matlab in real system).
(I don't know why. Maybe because virtual system (OS X 10.9) has a influence on real system (OS X 10.10) and makes Matlab think you install it on OS X 10.9.)
_3. Then you should follow these two videos step by step to let Matlab run in OS X 10.10!
https://www.youtube.com/watch?v=GoQnzIyOkB0
https://www.youtube.com/watch?v=HAMyQEOHWh0_
Good luck!
  11 Comments

More Answers (5)

Mc128k
Mc128k on 2 Sep 2014
Edited: Mc128k on 2 Sep 2014
Actually there is a much better way to run it on Yosemite. It runs fine without system hacks or desktop aliases.
  8 Comments
Tom
Tom on 20 Oct 2014
Here is a patch I made from Mathwork's official patch. It works on versions prior to R2013b (unlike the official patch) without modifying the SystemVersion.plist. I've confirmed R2013a and R2012b but I assume others will work as well.
To install:
  1. Extract patch.zip
  2. Right click on MATLAB_R20XX.app in your Applications directory and click "Show Package Contents"
  3. Place the extracted folder (named "patch") into the MATLAB_R20XX.app/java folder (alongside the existing jar and jarext folders)
You may still need to run Matlab by double clicking MATLAB_R20XX.app/Contents/MacOS/StartMATLAB. To avoid this you can temporarily change your SystemVersion.plist (as described in other posts here), launch Matlab, change the SystemVersion.plist back, and now Matlab will work by double clicking the .app.

Jordan Schmidt
Jordan Schmidt on 17 Oct 2014
Edited: Jordan Schmidt on 21 Oct 2014
For R2012a through R2014a , there are two fixes available:
  • One will remove the 'cancel' icon over the MATLAB icon, and will resolve the "You can't use this version of the application" message.
  • The other will resolve a Java error when attempting to launch MATLAB.
These fixes can be accessed through the following MathWorks Answer:

LNAKTDE
LNAKTDE on 28 Jul 2014
Same problem here!

freebil
freebil on 29 Jul 2014
Try this but i dont know if it will work..
1- find Matlab application file under Applications folder 2- Right (Control) click and select "Show Package Contents" 3- Navigate to : "Contents/Mac OS" 4- Right (control) click on "startMatlab" file 5- Make an Alias 6- Copy the Alias to another folder e.g. your desktop. 7- Run the alias.
  2 Comments

Weichao
Weichao on 14 Oct 2014
  1 Comment
Hongbo Miao
Hongbo Miao on 14 Oct 2014
Edited: Hongbo Miao on 14 Oct 2014
Hi, I tried this patch. This patch only works for Matlab 2013b and 2014a on Yosemite Beta 1 or DP 1. For new Yosemite above Beta 1 or DP 1, still need use Mc128k's patch. Anyway, thank you again.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!