Why do I receive an 'Invalid input argument of type 'double'. Input must be a structure or a Java or COM object' error while loading data in a simbiology fit program?

65 views (last 30 days)
I deviced a kinetic model using simbiology, simulated it and everything worked fine. Then I loaded a data set from excel containing three columns: ID, Time and concentration. I set ID as group, Time as independent and concentration as depended variables. But when I run the program it says
Invalid input argument of type 'double'. Input must be a structure or a Java or COM object.
I've also tried loading the data directly from the workspace and it gave the same error.
I converted the data to a structure and that is not listed as a valid input type while importing a dataset. I checked online tutorials and everyone seems to be able to load 'double' types.
The reaction is just A+B-->null
And dB/dt = -k*[B] and A is constant
  5 Comments
Florian Augustin
Florian Augustin on 29 Aug 2022
Edited: Florian Augustin on 29 Aug 2022
Hi Marc,
You might be seeing a different issue with the same symptom. I just confirmed that the issue Archishman reported is fixed in R2022a. Can you share reproduction steps that lead to the error? Are you working with the general release, or do you have an update version of R2022a installed? Which operating system are you working on? If you do not want to share this information publicly on MATLAB Answers, please contact MathWorks Technical Support.
Thank you,
Florian

Sign in to comment.

Accepted Answer

Fulden Buyukozturk
Fulden Buyukozturk on 19 Oct 2021
Edited: Fulden Buyukozturk on 19 Oct 2021
Are you running R2021b and is your dataset has only one group? If so, this is likely a known bug with the app that affects datasets with no group or one group.
You could use the command-line interface fitproblem instead of the app or run the app in R2021a. Sorry for the inconvenience.
  2 Comments
Fiona
Fiona on 13 Mar 2023
Hi Fulden,
I am getting this error :
"
Error using fieldnames
Invalid input argument of type 'cell'. Input must be a structure or a Java or COM object.
Error in BIDSFetcher/getPreopAnat (line 300)
templateOrder = fieldnames(obj.spacedef.norm_mapping)';
"
I am trying to open a BIDS format folder in lead dbs developer mode.
I DO have R2021b installed, however my PhD supervisor also has R2021b installed and does not have the same error. He does have a lot more matlab applications installed than me, and it would be very difficult to find out which app is responsbile for the differene between our machines, considering he has so many that I do not.
Do you have any ideas on a fix for this?
Thanks
Fiona
Fiona on 13 Mar 2023
These are the parts of the code in the same file "BIDSFetcher.m" where it refers to obj.spacedef.name:
% Set base dir and base name
templateSpace = obj.spacedef.name;
baseName = fullfile(LeadDBSDirs.normDir, 'transformations', ['sub-', subjId, '_from-']);
"
and
% Set normalized anat images
templateSpace = obj.spacedef.name;
session = fieldnames(coregAnat);
for i=1:length(session)
modality = fieldnames(coregAnat.(session{i}));
for j=1:length(modality)
anat = strrep(coregAnat.(session{i}).(modality{j}), LeadDBSDirs.coregDir, LeadDBSDirs.normDir);
normAnat.(session{i}).(modality{j}) = strrep(anat, obj.anchorSpace, templateSpace);
Is it possible to make obj.spacedef.name a structure somehow?

Sign in to comment.

More Answers (0)

Communities

More Answers in the  SimBiology Community

Categories

Find more on Scan Parameter Ranges in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!