MATLAB Answers

0

why don't these two transfer function models produce same open loop results?

Asked by John Hudak on 28 Jan 2015
Latest activity Answered by Mischa Kim
on 30 Jan 2015
I create a transfer function in simulink, drive it with a step input to look at open loop response, and observe the response on a scope. I create the same model in matlab, drive it with a step, and get a completely different response. I do not understand why. Here are the two models:
SImulink Step block (parameter range 0-1) Transfer Fcn block, 1/s^^2 + 10s +20 (Num coeff = 1 , Denon coeff = [1 10 20] ) Scope block
Matlab: s = tf('s'); P = 1/(s^2 + 10*s + 20); step(P)
I have varied the ode soln approach, checked parameter ranges and types, still no joy. The matlab approach produces the correct results btw. ANy insight is really appreciated.
-John

  1 Comment

Can you attach your Simulink model? I get exactly the same results for both methods.

Sign in to comment.

1 Answer

Answer by Mischa Kim
on 30 Jan 2015

John, the only thing I can think of is the step time in the Simulink Step block. It's set by default to 1. Open the Step block, change the Step time to 0 and you should get the same result. I do:

  0 Comments

Sign in to comment.