Simulink Support Package for Raspberry Pi Hardware not working on Raspberry Pi 4B 8GB (2022)

16 views (last 30 days)
Hey there,
I have just bought a Raspberry pi 4B 8gb. Former was Pi 4B 4GB. Although there is no problem with 4GB version ( I can use even external mode of Simulink with 4 GB version), newer one does not take image of Raspbian correctly. When I write image file to the SD card and insert it, on the black screen i see an error like ' does not support this version. use the latest version from raspberrypi.com'. So, i need a full image of Raspbian bullseye which includes Simulink support package.
Anybody has the same problem?
Thanks in advance.
Raspberry Pi 4B 8 GB
Matlab R2021a

Accepted Answer

Prasanth Sunkara
Prasanth Sunkara on 3 Oct 2022
Hi Haris,
One quick alternate way to set up pi's OS with libraries and packages is using " Customizing the existing Raspbain OS " option of hardware setup app.
As mentioned in our earlier conversations, bullseye is not officially supported by MathWorks. You can try the legacy Buster version and run the hardware setup app as mentioned above
Hope it helps!
Thanks,
Prasanth

More Answers (1)

Walter Roberson
Walter Roberson on 3 Oct 2022
It will not exactly be "fun", but if you look at https://github.com/mathworks/Raspbian_OS_Setup you can see a list of packages you need to include to generate a custom image file.
  1 Comment
Haris Ç
Haris Ç on 3 Oct 2022
Hey there. Thank you for your answer. I have already installed Matlab packages for bullseye version as detailed in that link. It works well. But, I asked for Simulink support package. So, that link does not include that yet.

Sign in to comment.

Categories

Find more on MATLAB Support Package for Raspberry Pi Hardware in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!