Clear Filters
Clear Filters

UIalert icon disappears in deployed application

24 views (last 30 days)
I have been working on an App Designer application in Matlab 2023b with Update 7. I deployed using the Standalone Desktop Application compiler and noticed that all uialert icons do not display when running the executable. When running from source they show up correctly as shown below.
However, when running a compiled application they disappear (shown below).
Initially I thought it was an issue generated when I converted my original app from 2023a to 2023b, however I tested this just by creating a new 2023b app with
uialert(app.UIFigure,'Test Alert','Icon Error', 'Interpreter','html', 'Icon','warning');
in the startupFcn and nothing else. Deploying this with the application compiler has given the results in the image above. There are no warnings or errors in the console when I run th application. When I deploy the same app in 2022a or 2023a the icon does show up properly.
I have reset my Windows Explorer icon cache as suggested in this post:
but it has not solved the problem.

Accepted Answer

Adam Danz
Adam Danz on 17 Apr 2024
Edited: Adam Danz on 17 Apr 2024
Thanks for reporting this, David.
We are aware of the problem. Stay tuned for updates.
  2 Comments
Sébastien Doré
Sébastien Doré on 24 May 2024 at 18:35
Hello Adam,
It looks like its not fixed in 2023b Update 8 yet (latest as of writing).
Any ETA on this issue being fixed ?
Thanks!
Steven Lord
Steven Lord on 24 May 2024 at 18:43
I believe this is Bug Report 3164120. If that's correct it is listed as fixed in release R2024a. If you want you can follow the Bug Report to be alerted when or if it is updated for an Update of release R2023b.

Sign in to comment.

More Answers (0)

Categories

Find more on Get Started with MATLAB in Help Center and File Exchange

Products


Release

R2023b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!