How to fix 'Error Adams(server) simulation startup. AEI_Initialize: Error in initialization.'

56 views (last 30 days)
When I try to compile a very simple system (an Adams_sub with one input/output and a scope) i always get: 'Error in Adams(server) simulation startup. AEI_Initialize: Error in initialization.'
Does anyone already had this issue and/or have an idea to fix it?
Thank you for your help!

Answers (3)

Allen Chiang
Allen Chiang on 7 Mar 2016
i have also come across this problem. have you found the solution?

Wan Ding
Wan Ding on 31 May 2017
You need to check the following addresses to be sure that “ADAMS” built the "adams_plant.mexw32" or "adams_plant.mexw64"file:
Addresses in your computer: If you use “ADAMS 32-bit”: C:\MSC.Software\MD_Adams\2011\controls\win32 If you use “ADAMS 64-bit”: C:\MSC.Software\MD_Adams_x64\2011\controls\win64
If it's missing, you need to download from ADAMS.
Please note that, if you use “MATLAB 64-bit”, you have to compile your model in “ADAMS 64-bit”. Because, “Matlab 64-bit” does not support the “.mexw32” files. And in this case you have the same error.

Johannes Korsawe
Johannes Korsawe on 23 Nov 2022
I ran into the same error. My problem had been deprecated ADAMS model/maneuvre files. I used ADAMS model/maneuvre files from BEFORE i exported the controls plant.
My fix:
Use Controls plugin to export Plant for Matlab first. Export model/maneuvre again with "files only" option.
Start Matlab again. Use adams_sys to build new (!) adams_sys_ model. Take cosim block from there and build up new control system model.


Find more on Programmatic Model Editing in Help Center and File Exchange


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!