Why "Name is nonexistent or not a directory" only when Adminstrator?

13 views (last 30 days)
In the past couple days, Matlab has developed some strange behavior: If I run it as an administrator, it can't seem to access a remote drive ("Name is nonexistent or not a directory" upon startup when it tries to load my path; can't change directories to that drive), even though I can access that drive outside of Matlab. However when I run Matlab as a non-administrator, the error doesn't happen and I can access directories on the drive. What could be going on? More details: The drive is a NAS device mapped to a drive letter on my Windows 7 machine, and I am running 2015b.
K E on 22 Jan 2016
Yes, the actual network path works when I am running Matlab as admin. I will ask about NFS. The strange thing is that I previously was able to access that NAS when running Matlab as an admin.

Sign in to comment.

Answers (0)


Find more on Startup and Shutdown in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!