MATLAB Answers

BerlinM
0

Matlab command window doesn't work

Asked by BerlinM
on 5 Feb 2016
Latest activity Answered by Komal Gupta on 14 Oct 2018
Hi, my Matlab Command window doesn't work. The two arrows right next to the fx are missing. If I type in something trivial like "a=3" nothing happens. I jump in to the next row but nothing happens. Please help me!
Here is a picture of what i mean.

  3 Comments

did u find any solution, I have a same problem
i'm with the same problem here on windows 10. do you get some solution to repair it?
I have the same problem, please suggest some solution.

Sign in to comment.

Products

6 Answers

Answer by Steven Lord
on 5 Feb 2016

Show the lower-right corner of the Command Window. Does it say something like "Initializing" or "Busy" there?
If it shows "Initializing", how long has it been initializing? How long since you started MATLAB?
If it shows "Busy", MATLAB is running some code. Depending on what that code is doing, it may take a while and you won't be able to execute other commands while that code is running. You can type ahead but they won't get executed until MATLAB has finished its current work.

  2 Comments

One step forward: It shows Initializing the whole time (for 5 minutes now).
Thank you, what can I do?
If MATLAB is taking a long time to initialize and start up, try the steps in this Answer. If none of those resolve the problem, you should probably contact Technical Support using the Contact Us link in the upper-right corner of this page and work with the Support staff to diagnose why initialization is taking a long time.

Sign in to comment.


Answer by the cyclist
on 5 Feb 2016

You aren't really giving us much info here besides the core problem. Has it been working, and suddenly stopped? Or is this the first time you've used MATLAB?
Have you tried the obvious things like restarting MATLAB? Restarting your computer?
Have you changed anything significant on your computer before/after this problem?
This seems like a problem we might struggle to diagnose with you. You might want to contact Mathwork support.

  3 Comments

I didn't use MATLAB for some month. Today I needed to use it, so I started it and it didn't work. After restarting MATLAB several times I deleted it from my PC and loaded the latest version. Same problem.
I do not really know how I can give you more Information about my problem. Nothing works...
Thank you for your answer!
Do you have a startup.m in your C:\Users\S\Documents\MATLAB or in your MATLAB preferences directory ? If you do then remove them.
Yes, I found it in the preference directory and I removed it. But it didn't solve my problem.

Sign in to comment.


Answer by Eric Smith on 11 Jan 2018

I had the same problem, but restarting the program worked for me. What was absent for me before when it wasn't working (and appears to be absent in yours) is the two right facing carrots on the command line. I've just started using the program but if someone with more experience could pinpoint why those might disappear, that would most likely fix the problem.

  0 Comments

Sign in to comment.


Answer by Eliot Mayer on 23 Jan 2018

> ... What was absent for me before when it wasn't working (and appears to be absent in yours) is the two right facing carrots on the command line.
Sorry, I don't have an answer. I just want to report that I have been having the same problem lately with Matlab R2017b, running on Windows 7. I am not new to Matlab or R2017b, but the problem seems to be happening daily for the past few days. The problem is intermittent.
When the problem arises, I don't have that command prompt, and yet Matlab is not "dead". For example, I can still click on the tabs in the Editor window and view the code from the open functions. I can even edit and save those functions. I can undock and dock the Command Window (but the >> prompt is missing either way). I can type in the command window, but it dot respond.
The problem shows up when running my code. I can force Matlab to close. When I restart Matlab, I can run the same code without problem, so I don't suspect coding problems such as endless loops. Even if that was a problem, I would think the Pausing button would give back control, but it does not.
One clue: When I click the X to close Matlab, I get a message "An operation is in progress". I give it a chance to try to stop the operation, but that does not work. Then I click End Now. I just did this, re-started Matlab, and ran the same code that "got stuck". It ran normally again, completing in about 10 seconds.

  4 Comments

Show 1 older comment
Walter, I didn't see your question until just now - sorry. We do have OneDrive on our work computers, though I probably was not using it actively at the time. At any rate, I have not seen this problem in a long time.
There was an issue with Microsoft OneDrive that had automatic download turned on; it was an interaction between MATLAB and a Microsoft change. It affect R2017b; I do not recall at the moment if it also affected R2017a. There was, if I recall, a patch for it for the affected release, and was fixed in the next release of MATLAB.
Thanks, Walter. I have been procrastinating about updating Matlab but you just inspired me to do it.

Sign in to comment.


Answer by Emily Garvin on 10 Oct 2018

Hi. It sometimes simply happens to me when I forget to end a if/for/while statement. In this case I was unable to solve the problem by restarting the program. All I had to do was type "end" or type a closing bracket, even after reopening the program. :)

  0 Comments

Sign in to comment.


Answer by Komal Gupta on 14 Oct 2018

Exactly the same happened with me...n i typed an end and its resolved ...it works.

  0 Comments

Sign in to comment.