Simulink TI C2000 Boot mode

19 views (last 30 days)
Oliver
Oliver on 30 Aug 2016
Commented: Devpriy Yadav on 23 Feb 2022
Hello,
I'm running simulink models on an TI C2000 F28069M Launchpad. The launchpad has three switches to select the boot mode (see attached User's guide section 5.3). I can load a model to the launchpad when switch 3 is in up position.
It runs as expected, but when the power supply is taken away and then reapplied, the code doesn't start running. Therefore, no standalone operation is possible. Standalone operation only works with the switch in down position, but then the debugger can't connect to the launchpad.
Is there a way for getting standalone operation and being able to load new models without having to change the position of the switch every time?

Accepted Answer

Antonin
Antonin on 7 Aug 2017
Hi,
This is a late reply for a question that is still relevant today. To be able to load code automatically from MALTAB/Simulink and be able to run it in standalone mode, all boot switches need to be places towards the "ON" label on the LAUNCHXL-F28069M Launchpad. For standalone operations, make sure to enable the "boot from flash" option in the configuration parameters of your Simulink model.
I hope it helps,
Antonin.
  2 Comments
Devpriy Yadav
Devpriy Yadav on 23 Feb 2022
Hi Antonin,
I am using Launchpad 28069M and I am using Simulink to upload code. All the Boot Swithces are in "ON" position and "Boot from flash (standalone execution)" check box is also checked in Hardware Implementation.
The code works well when uploaded, but if I press reset button or unplug and plug it again to test standalone execution, it is not working.
May you please help me with the issue.
Thanks
Dev

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!