MATLAB Answers

Is Xcode 8 compatible with MATLAB R2016b?

17 views (last 30 days)
Is Xcode 8 compatible with MATLAB R2016b?

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 11 Aug 2021
Edited: MathWorks Support Team on 25 Aug 2021
Yes, Xcode 8.x is supported by MATLAB R2016b.Please refer to the supported compilers page (link provided below) under the Mac section:
  1 Comment
Walter Roberson
Walter Roberson on 13 Aug 2017
This answer is contradicted by https://www.mathworks.com/matlabcentral/answers/305895-is-the-matlab-compiler-and-matlab-runtime-compatible-with-macos-sierra which says that R2016b should be able to find XCode 8 but that XCode 8 was not a supported compiler for R2016b.

Sign in to comment.

More Answers (1)

Bull Durham
Bull Durham on 2 Jan 2017
Once I removed 2015b as the default MATLAB, the 2016b mex function worked fine with XCode 8.2.1. If I have any future problems I'll follow your suggestion. Thanks.

Products


Release

R2016b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!