MATLAB Answers

Why do I see a "java.util​.zip.ZipEx​ception" error in my installer log file when I try to install the MinGW support package?

116 views (last 30 days)
When installing the MinGW Support Package, I see the following error:There was a problem installing the third-party software. To resolve this issue, contact Technical SupportI also see the following inside of my MATLAB installer log can I proceed with installing this Support Package?

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 12 Aug 2021
Edited: MathWorks Support Team on 25 Aug 2021
This error was due to incomplete third-party downloads through the MATLAB Support Package installer. This issue has since been resolved. The current solution is to download and install the MinGW Support Package through the MATLAB client using the following method:
How to install MinGW 4.9.2 for use in MATLAB?​

Sign in to comment.

More Answers (24)

Jonathan Eagle
Jonathan Eagle on 8 Mar 2017
Edited: Walter Roberson on 26 Mar 2017
This is the response from mathworks with instructions that worked for me. The other instructions here did not.
Thank you for this followup information. I think there may be some confusion with the workaround instructions, as you should not need to rename any files or folders during this process. Once you have downloaded the 5 zip files, they need to be placed in the following folders found at C:\Users\<your_username>\Downloads\MathWorks\SupportPackages\R2016b\archives\3p:
  • '"" placed in "tdm_mingw64runtime.instrset_win64_1473452065" folder
  • "" placed in "tdm_mingwbinutils.instrset_win64_1473452064" folder
  • "" placed in "tdm_mingwcpp.instrset_win64_1473452064" folder
  • "" placed in "tdm_mingwdebugger.instrset_win64_1473451976" folder
  • "" placed in "tdm_mingwgcc.instrset_win64_1473452033" folder
Once the zip files are placed in each of these folders, you need to run the same MinGW support package installer again (from Add-Ons Explorer). The installation will now proceed and skip over the section where it needs to download third-party files.

Sign in to comment.

Travis Allen
Travis Allen on 23 Feb 2017
I'm currently getting this error when trying to install via the steps above...
"There was an error installing third-party software for Support Package mingw: C:\MATLAB\SupportPackages\R2016a\downloads\mingw_download does not contain archives for third-party software used by the support package.
To continue with support package installation: Use "Install from Internet" or Use "Download from Internet" to download the complete set of files, and retry installing from folder."
Any insights on how to fix this?
Kyle Perry
Kyle Perry on 8 Mar 2017
Hello Everyone,
If you are still experiencing these issues, there could be several causes, the zip files were automatically extracted and they were not supposed to, or that the zip files are corrupt. Please contact us so we can help resolve the issue.

Sign in to comment.

Tanay Rastogi
Tanay Rastogi on 28 Feb 2017
I have copied the 5 zip files in the folder, as mentioned by the MATLAB support team. After that, i run the the "mingw.mlpkginstall" MATLAB support package installer. I still see the error.
I have a question here, that when I run the package installer again, does it replace the files i copied in the folder. Because, it again downloads all the files (not sure what happens to files I copied). - Is that an issue? - How to directly install the files, without downloading them again? (Package Installer downloads them again)
Kyle Perry
Kyle Perry on 8 Mar 2017
Hello Tanay and Reza,
The files you downloaded manually should replace the existing files in the support package folder. If they are being re-downloaded after you replace them or the install is still not working, then please contact us so we can help resolve the issue.

Sign in to comment.

Koen V
Koen V on 24 Mar 2017
Edited: Koen V on 26 Mar 2017
Hi All,
Problem: Unable to install MinGW through Add-on Explorer in Matlab R2017a (fresh install of Matlab and Windows7).
In my case, the description above was causing some misunderstanding because these steps deviated slightly from the actual required workflow.
FOR ME THE PROBLEM IS SOLVED after doing the following procedure:
1. Try to install through 'Get Add-ons' in Matlab 2017a
2. Resulted in a Download error: There was a problem downloading the third-party software. To resolve this issue, contact Technical Support
3. Downloaded all files as described by Mathworks support team:
4. It is stated that the installation process has already created some folders in: “C:\Users\_<username>_\Downloads\MathWorks\SupportPackages\R2016b\archives\3p\<name_of_archive>\”
However, these folders did not exist in my case. On the contrary, some zip-folders are created in a different location; "C:\Users\_<username>_\Downloads\MathWorks\SupportPackages\R2017a\archives\win64\3p" The folder naming of these folders does comply the description as stated before; "The name_of_archive would be one of the following and where xxxxxxxxxx is a string containing numbers.e.g.: tdm_MinGW64runtime.instrset_win64_xxxxxxxxxx"
So I decided to use the names of these zip-folder in the following steps
5. I created a new 3p folder in "C:\Users\_<username>_\Downloads\MathWorks\SupportPackages\R2016b\archives\" and created 5 new folder inside 3p that have the same name as the zip-folder in "C:\Users\_<username>_\Downloads\MathWorks\SupportPackages\R2017a\archives\win64\3p"
6. Then I placed the 5 archive folders from point 3 in their corresponding folder:
binutils-2.24.51-20140703-tdm64-1 --> copy to archives\3p\tdm_mingwbinutils.instrset_win64_1487954571
gcc-4.9.2-tdm64-1-c++ --> copy to archives\3p\tdm_mingwcpp.instrset_win64_1487954573
gcc-4.9.2-tdm64-1-core --> copy to archives\3p\tdm_mingwgcc.instrset_win64_1487954592
gdb-7.8.1-tdm64-3 --> copy to archives\3p\tdm_mingwdebugger.instrset_win64_1487954574
mingw64runtime-v3-git20141130-gcc49-tdm64-1 --> copy to archives\3p\tdm_mingw64runtime.instrset_win64_1487954589
7. Retry to install through the Add-on Explorer
I hope this helps you to solve the problem.

Jed Frey
Jed Frey on 14 Apr 2017
The reason this is happening is because SourceForge redid their web structure. The Matlab downloading tool isn't respecting their 302 status code.
If you open the 1kB 'zip' files with Notepad++ (or any other text editor) you will see something like this:
<title>302 Found</title>
<h1>302 Found</h1>
The resource was found at <a href=""></a>;
you should be redirected automatically.
The fix should be as simple as either:
  1. Teaching the downloading tool to respect HTTP return codes.
  2. Fix the URLs in the packager.
For those downloading the files manually, make sure to delete the existing 1kB files. Windows will sometimes automatically just rename the files with (1) at the end instead of asking if you want to replace the existing files.

Matt Ward
Matt Ward on 13 Mar 2017
Edited: MathWorks Support Team on 19 May 2021
I ended up on this page after failing to create an Excel Add-In using Matlab Compiler 2016a. It turns out MinGW is not a supported compiler for Excel Add-Ins, contrary to the log file error. See compatible compilers here:
For those trying to get the Excel Add-In working, the freely available Windows SDK 7.1 will work . I ran into some issues for me on Windows 10 using Microsoft's web-based installer file (the small file that will trigger a download for missing/desired components) however, I found success following the approach described here, where you download the .ISO:

Fengzhou Wang
Fengzhou Wang on 16 Mar 2017
is there anyone could show how to solve the problem from Mathwork Support. Do not ask everyone to ask for Mathwork Support.
mprice on 17 Mar 2017
One issue I had was that I was extracting the sourceforge zip files into the specified folder (for 2016a). The zip files themselves must be present in this folder in order for the install to succeed.

Sign in to comment.

Mengnan Zhao
Mengnan Zhao on 6 Apr 2017
If you follow this instruction, the only reason that you still have the same problem before is that the downloaded zip files are not complete. To check this, you should open the zip files to see whether it can be unfolded. If yes, I guess you probably can succeed. This is how I fix the problem.

Trinh Nguyen Cong
Trinh Nguyen Cong on 11 Apr 2017
I use R2015b and this work for me. First I copied all zip files to the folder "C:\MATLAB\SupportPackages\R2015b\downloads\mingw_download" and renamed the files as the instruction said but it still got error. Then I delete all zip files and copied them again without renaming and it worked. Hope this help!

Seyed Hamid Mirmohammad Sadeghi
I tried to follow all the steps that mentioned here, but unfortunatly I have problem of installing the support package and it gives me an error. my matlab is matlab 2016b. what should I do? anybody tries this instruction for matlab 2016b?

Kaveh on 19 May 2017
It is ridiculous that after MONTHS the Matlab installer is still not fixed for this.
  1 Comment
Kyle Perry
Kyle Perry on 25 May 2017
Hi Kaveh,
This issue was resolved in R2017a. Also for R2016b we have a patch available to install that resolves the issue as well, I have attached the link below:
If you are using R2015b or R2016a and still have the issue, please contact us so we can assist.

Sign in to comment.




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!