MATLAB Answers

Using Java API gives "no nativemvm in java.library.path"

169 views (last 30 days)
Jim Person
Jim Person on 13 Jan 2017
Commented: Michaela Rikard on 5 Oct 2017
I am attempting to work through the example code for the Java Matlab engine API (Note: this is calling Matlab FROM Java): https://www.mathworks.com/help/matlab/matlab_external/java-example-source-code.html
I can get to the last step, then I get the error: "java.lang.UnsatisfiedLinkError: no nativemvm in java.library.path". FYI I get this same error when trying to run my own code linked to Matlab in Eclipse.
Does anyone know how to fix this? Or know of any other information/examples/tutorials on calling the Matlab engine from Java? (This is a very new feature in 2016b so there is not much information out there)

  1 Comment

Michaela Rikard
Michaela Rikard on 5 Oct 2017
I am having the same problem. I have added the matlabroot/bin/maci64 to both the PATH and DYLD_LIBRARY_PATH and am getting the same error: no nativemvm in java.library.path. It seems like people have been able to get this to work by adding to the PATH in Windows. Has anyone had success on a Mac?

Sign in to comment.

Answers (5)

Jim Person
Jim Person on 13 Jan 2017
Answering my own question: I used the suggestion to add matlabroot\bin\win64 to the PATH permanently using the Windows UI, instead of temporarily in Eclipse/cmd, and the code compiles now (the example problems and my own).

  6 Comments

Show 3 older comments
Jose Cano
Jose Cano on 13 Mar 2017
I am blocked with the same error : "com/mathworks/mvm/MvmFactory.nativeSetJavaEngine(Z)V" Any help would be greatly appreciated.
happy
happy on 24 May 2017
Came across this, having the same error: com/mathworks/mvm/MvmFactory.nativeSetJavaEngine(Z)V
May I know how you resolved it?
Thank you!
SK
SK on 26 Jun 2017
I am also having this error--has any one been able to figure out a solution?
Thanks for the help!

Sign in to comment.


J.Eric Tkaczyk
J.Eric Tkaczyk on 13 Feb 2017
This also worked for me, but I had to first exit and restart my IntelliJ IDE after changing the PATH on the Windows Environment Variables

  1 Comment

Christoph Müller
Christoph Müller on 21 Jun 2017
I still have this problem (also with IntelliJ IDE) despite changing the PATH on the WIndows Environment Variables. Could you please explain hoe you were to solve this issue step by step? It seems that I am missing something here. Thanks!

Sign in to comment.


ant
ant on 23 Mar 2017
you need to add the matlab library to your IDE(eclipse or others) or System (if you don't use any IDEs ), see below:
that's the right solution.


Kobe Van Reusel
Kobe Van Reusel on 15 Mar 2017
I'm having the same problem but can't find the solution for it.
I added the path to my PATH variable and added the engine.jar to my library but stil it gives me the "no nativemvm in java.library.path" error.
Can someone explain all the steps he took to get it working? Is it important where the engine.jar file is located or can i put it in the working directory of my project?
I'm using osx with netbeans and downloaded Matlab R2017a.

  1 Comment

Bo Li
Bo Li on 15 Mar 2017
This is a quote from the file "<matlabroot>/extern/examples/engines/java/README" for Mac:
Run the examples by adding "<matlabroot>/bin/maci64" to the Java library search path without setting the DYLD_LIBRARY_PATH variable:
java -Djava.library.path=<matlabroot>/bin/maci64 -classpath .:<matlabroot>/extern/engines/java/jar/engine.jar EngineConsoleDemo

Sign in to comment.

Sign in to answer this question.