fatal error: rtiostream_utils.h: No such file or directory

104 views (last 30 days)
Fumi_Maru
Fumi_Maru on 4 Jun 2017
Commented: Fumi_Maru on 9 Jun 2022 at 13:34
I have a trouble when I deploy my Simulink model to Raspberry Pi 3 hardware.
My Model works just fine in EXTERNAL MODE.
Just after running on EXTERNAL MODE, I deployed to the hardware.
Then, the error occurs.
I thought that the error is because "rtiostream_utils.h" is missing guessing from the error log.
I searched on the internet and there were some people that has the same problem.
I also went to the last part of the link below. "Software Interface Model Fails to Build". https://jp.mathworks.com/help/supportpkg/usrpembeddedseriesradio/ug/troubleshooting-hardware-software-co-design.html
When I deploy to the hardware, the simulation mode in the pull down window is "external".
Please give me some idea to solve this problem.
If you need any more information, please feel free to ask me.
I will be looking forward to hear from you soon.
Thank you.

Accepted Answer

Julia Antoniou
Julia Antoniou on 1 Feb 2018
Hi Fumi,
I was running into the same error when trying to deploy my model to hardware after previously running it successfully on external mode. I was able to resolve the error by changing my active configuration set. To do this:
1) In your Simulink model, go to View > Model Explorer > Model Explorer
2) In the left "Model Hierarchy" pane, select your model.
3) In the middle pane, see if "External Mode Configuration" is active (the icon will be green). If so, right click on the other listed configuration, and select "Activate". For me, this other configuration was just named "Configuration". This is what my model explorer looked like after activating the other configuration set:
4) Once I changed the simulation mode back to "normal" and tried building my model, the error was resolved.
Hope this helps!
-Julia
  10 Comments

Sign in to comment.

More Answers (1)

Arthur Preuss
Arthur Preuss on 7 Jun 2018
It solved my problem, thank you a lot!
I was actually able to run on external model, when suddenly it stopped being able to compile. Than I followed these steps and it worked well in external mode again.

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!