MATLAB Answers

6

CD to OneDrive doesn't work on Windows 10 build 16273.1

Asked by James Bell on 30 Aug 2017
Latest activity Commented on by James Bell on 19 Jan 2018
I recently upgraded to the newest version of the Windows available to insiders and now I can't CD to OneDrive in Matlab. I can still use "dir" to list the contents of the OneDrive folder, and I can even view the files in it that I had open previously, but I can't actually change the working directory to reach them. Symbolic linking and shortcuts also don't work. I can still cd to OneDrive from both Windows command line and the WSL terminal, so it seems to be a Matlab specific problem.

  1 Comment

Update: Try the update for R2017b delivered on https://www.mathworks.com/support/bugreports/1609674
It works at least for our machines.
Old Text:
This seems to be a Problem of R2017b. R2017a still works on the same machine with the same paths.
Damn I have to rely on some new Simscape library components...

Sign in to comment.

Tags

11 Answers

Answer by Srikanth Sedimbi on 6 Sep 2017
 Accepted Answer

If you disable the "Files OnDemand" feature of OneDrive, you should be able to access OneDrive files from MATLAB. This is a MATLAB specific issue and there is no workaround in R2017b or any of the earlier versions. A solution may be available in releases after R2017b

  11 Comments

They have forums to specifically avoid community interaction. You can always submit a bug, but they never responded to my reports before.
James Bell,
The Answers forum was modelled on StackOverflow, as a place for volunteers to interact. It was not created to "specifically avoid community interaction": it was designed as a tool to provide an enhanced service compared to the existing all-volunteer Usenet Newsgroup.
I have submitted a number of bugs through the official support services; I always get acknowledgement through that service.
@James Bell: I opened a Support ticket and got message on the same day. They are working on the Problem, but have no idea whether we'll see fixes for this release.

Sign in to comment.


Answer by Dyson Freeman on 23 Oct 2017
Edited by Dyson Freeman on 23 Oct 2017

I've confused and tortured by this issue for almost 3 hours. The File on Demand was indeed responsible for this. I also verified that R2015b was function normally when I turn off the File on Demand. But R2017b still can't recognize the OneDrive folder. HOWEVER, you can try to locate the subfolders under the OneDrive folder, my 2017b can open them all except the OneDrive folder itself.

  5 Comments

This is exactly what's happening to me. Matlab 2017b.
I cannot open the subfolders regqardless of files on demand beeing active or inactive. (R2017b on build 16299.19)
Same problem. Matlab R2016b, Windows 10 16299.19 and OneDrive 17.3.7076.1026.
Strangely, in R2015a there is no problem.
In other computer I work with, the Windows version is 15063.726 and I have no problems at all, despite having exactly the same version of One Drive.
Therefore, I think it is a problem of Windows, not OneDrive or Matlab.

Sign in to comment.


Answer by Jie Huang on 27 Oct 2017

It works for me if "Files on Demand" feature of OneDrive is disabled.

  4 Comments

Show 1 older comment
And what is your Windows build?
Matlab R2015a, Windows 1709 (OS 16299.64), and OneDrive 2017 (17.3.7076.1026).
@Jie Huang: The problem exists from R2017b on. R2017a and earlier should be no problem.

Sign in to comment.


Answer by Feiteng Li on 4 Nov 2017

So updating to 2017b vision, has the problem Onedrive path can't be writtable and read solved?

  3 Comments

No, the problem still exists.
+1 on problem still there.
I have no problems with using my directory under OneDrive in 2017a, but 2017b always give an error when I run the cd command. Interestingly enough, if you do cd, get the error, and dir, it did actually complete the cd command, but the tool will not make this the directory for running my program.
If I take the directory and put it in c:\Temp\<dir>, everything works find with 2017b. I even write protected the directory, and still no problems.
So something particular for cd under OneDrive.
Hopefully someone who has an in with the developers will see this and figure out what broke between 2017a and 2017b.
+1 on exactly the same problem here 2017b: I cannot access certain directories ('cd', via the 'open folder' dialog or by running a script in that directory) on the shared OneDrive (even if I disable Files On-Demand). On the non-shared OneDrive everything seems fine. 2017a: no problems at all.

Sign in to comment.


Answer by Purring Bytes on 5 Dec 2017

Files on demand is extremely useful feature, especially if your OneDrive is large (mine is 1.2 Tb) and you want to work from a laptop with limited space. This bug is clearly Matlab bug. All other programs (e.g. Mathematica, Origin) work just fine with OneDrive.

  0 Comments

Sign in to comment.


Answer by Andreas on 12 Dec 2017
Edited by Andreas on 12 Dec 2017

Any updates on this topic yet? A bunch of our Windows users is migrating to Windows 10 and will face this problem soon.

  1 Comment

My desktop never had an issue for some reason, but my surface pro did. I was able to path to all the subfolders after I created new folders and moved the data to them. The OneDrive folder itself though I still can path to, so while in Matlab I just have to expand the folder and path directly to one of the subfolders.

Sign in to comment.


Answer by Andreas on 14 Dec 2017

As of today, the MATLAB R2018a prerelease should be available. The support told me, this should fix the problem.

Answer by Andreas on 20 Dec 2017
Edited by Andreas on 20 Dec 2017

I get the following errors using R2018a:

  0 Comments

Sign in to comment.


Answer by Turgay Tekin on 31 Dec 2017

I have same problem with Matlab 2016a. Windows version is windows 10 Pro 1709 16299.125
I have changed Onedrive settings as you said and videos
"https://support.office.com/en-us/article/Learn-about-OneDrive-Files-On-Demand-0E6860D3-D9F3-4971-B321-7092438FB38E" but it still same.
If someone find the way how to fix, please share to us.

  0 Comments

Sign in to comment.


Answer by Andreas on 4 Jan 2018

Try the update for R2017b delivered on https://www.mathworks.com/support/bugreports/1609674
It works at least for our machines.

  0 Comments

Sign in to comment.


Answer by Artur Krupa on 19 Jan 2018

Problem is not related with "FOD" function of OneDrive, because it can be enabled. Problem is when file you want to open is just a symbolic link (On Demand file) or file downloaded physically. I have already updated my MatLAB to 2017bU4 and still have 90% of files with On-Demand feature, but only folders with MatLAB files are phycically here and now everything is working.

  1 Comment

So you're saying that a symbolic link not in a onedrive folder will still have problems opening?

Sign in to comment.