MATLAB Answers

Issue compiling vlfeat on mac : further insight ?

13 views (last 30 days)
PK
PK on 11 Oct 2017
Edited: Ramazan Limko on 14 Nov 2017
Hello everyone,
I am currently trying to run vlfeat on Mac OS Sierra (10.12) with Matlab version 2017b. I am having a real struggle here because of libraries not found :
Invalid MEX-file : Library not loaded: @loader_path/libmex.dylib
Although I read carefully these explanations here or there about recompiling vlfeat, I can't make it work. Here is the error message I get when trying with Xcode 9 or Xcode 8 (tried both, same result) :
ld: symbol dyld_stub_binding_helper not found, normally in crt1.o/dylib1.o/bundle1.o for architecture x86_64
fatal error: /Users/paulkovacsik/Downloads/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool: internal link edit command failed
make: *** [bin/maci64/libvl.dylib] Error 1
I understand it has to do with my compiler (probably gcc), but would anyone have some hints about how to fix this ? I would be greatly thankful, as I am right now quite desperate !
Thank you in advance
PS: commands used were (Xcode, 8 or 9)
make MEX=/Applications/MATLAB_R2017b.app/bin/mex ARCH=maci64
  8 Comments
Keshav Kundassery
Keshav Kundassery on 25 Oct 2017
Thanks, that let me verify the path, but I'm still getting the same error when running "vl_version verbose"

Sign in to comment.

Answers (2)

Ramazan Limko
Ramazan Limko on 14 Nov 2017
Edited: Ramazan Limko on 14 Nov 2017
I had exactly the same problem and managed to solve it. Firs of all make sure you have the lates version of Xcode and Clang compiler. Then open up a terminal and 'cd' to the directory where you have stored the VLFeat:
cd /<your root>/vlfeat-0.9.20
Then:
make MEX=/<your root>/MATLAB_R2017b.app/bin/mex
I hope it works for you too.

Meeshawn Marathe
Meeshawn Marathe on 24 Oct 2017
It seems like some libraries may not be loaded since the DYLD_LIBRARY_PATH path may not be set properly. Try setting the DYLD_LIBRARY_PATH path from MAC terminal. For example:
DYLD_LIBRARY_PATH='/Applications/MATLAB_R2017b.app/bin/maci64:/Applications/MATLAB_R2017b.app/sys/os/maci64':$DYLD_LIBRARY_PATH
Verify the path:
$echo $ DYLD_LIBRARY_PATH

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!