Build problems due to TflCheckSum difference

38 views (last 30 days)
Stefan Brönnimann
Stefan Brönnimann on 20 Oct 2017
Commented: Tong Zhao on 2 Feb 2022
I try to compile a model with Subsystems and get following error message:
Error building model 'OCV_SOC_calculation'. The current model configuration differs from the model configuration used to generate the shared utility code folder, 'C:\local_data\ESREC\SOCmodel\slprj\ert\_sharedutils'.
If I check the parameter difference, the only difference between the model and the sharedutil folder is the TflCheckSum, which i cannot modify in the parameter dialog. All other params are equal.
Thanks a lot for the help!

Answers (4)

Bhavanithya Thiraviaraja
Bhavanithya Thiraviaraja on 8 May 2018
Hi,
I had the exact same problem. The configuration parameters of the top model and the referenced models have to be the same.
I found that there was a difference in the " Code Generation - Interface" Setting in my model. The Standard math Library of the top model was "C99(ISO)" whereas the referenced models had "C89/C90(ANSI)". After changing it to "C99(ISO)" the problem got resolved.
  1 Comment
Tobias Huth
Tobias Huth on 19 Jul 2018
I had the same issue with my model. Luckily, I found your answer after just 2 hours of trying to fix it myself.
Thank you!!

Sign in to comment.


Julia Antoniou
Julia Antoniou on 25 Oct 2017
Hi Stefan,
To resolve this error, I would first recommend deleting any "SLPRJ" folders the compiling may have created, and then trying again to compile the model.
I do not believe there is anything specific to subsystems that would cause this error. If your model has model references, this error could be caused by conflicting Configuration Parameters within those model references. If your model has S-Functions, try regenerating any MEX files needed for the model.

Stefan Brönnimann
Stefan Brönnimann on 27 Oct 2017
Hi Julia
Thanks a lot for your support. I tried to delete the slprj or the _sharedutils Folder and all other temporary files, but with the same result. During the compile process, it generates the _sharedutils folder and when compilation gets to one of the Subsystems, it fails because it sees different config parameters. In the error message, I can open a dialog which compares the two settings, and the only thing that is marked as different is the TflCheckSum. Can i modify this checksum somehow?
  1 Comment
Tong Zhao
Tong Zhao on 2 Feb 2022
Hi Stefan,
Have you resolved this problem? I have exactly the same issue like yours. The TflCheckSum is the only difference between top level model and referenced model. Specifically my error message reads:
Error using coder.internal.infoMATFileMgr
Error building model 'SiMappedEngineV'. The current model configuration differs from the model configuration used to
generate the shared utility code folder,
'C:\Users\xx\MATLAB\Projects\examples\SS\main\Work\slprj\rsim\_sharedutils'.
Click here to review parameter differences between 'SiMappedEngineV' and
'C:\Users\xx\MATLAB\Projects\examples\SS\main\Work\slprj\rsim\_sharedutils'.

Sign in to comment.


roberto crippa
roberto crippa on 11 May 2018
Edited: roberto crippa on 11 May 2018
Hi all,
I have the same issue with a model that: - refers others models;
- some of them are model with an S-function model block only, other let's say standard Simulink blocks;
- s-function model has Standard math Library set to "C99(ISO)" while others has "C89/C90(ANSI)"
- when building I get the TflCheckSum difference
After aligning the Standard math Library settings this issue is gone.
Thanks Bhavanithya Thiraviaraja for sharing the hint!!! It save me days of investigation.
Roberto

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!