MATLAB Answers

No supported Visual C/C++ compiler found. Check your installation of Visual C/C++.

41 views (last 30 days)
Ajay
Ajay on 22 Mar 2011
Hi,
In simulink I made a simple block and generating a visual C++ code using a target file : grt.tlc ----- (Creating a visual c++ solution file for the grt target. During Build process I am getting an error like:
'No supported Visual C/C++ compiler found. Check your installation of Visual C/C++.'
But still it is genearting some code. But this error is really annoying me. On the other side, in matlab command window, it shows like:
''### Real-Time Workshop build procedure for model: 'convFactor2' aborted due to an error.''
By seeing this I feel that, the genearted code is not completly build because when I then launch it on VC++ itself I get errors from simulink header files (particularly on simstruc.h).
However when I type command "mex -setup" it shows both the lcc compiler and VC++ compiler. I have thus chosen the VC++ compiler but still get the same error as explained previously.
So, how do I get the RTW to recognize the VC++ compiler?
Note:I am using Matlab R 2010b and Microsoft Visual C++ 2010 express edition and also I have installed microsoft SDK.
Thanks in advance

  2 Comments

Kaustubha Govind
Kaustubha Govind on 22 Mar 2011
What happens when you run "mex.getCompilerConfigurations" at the command prompt?
Ajay
Ajay on 22 Mar 2011
I get the following info....
>> mex.getCompilerConfigurations
ans =
mex.CompilerConfiguration
Package: mex
Properties:
Name: 'Microsoft Visual C++ 2010 Express'
Manufacturer: 'Microsoft'
Language: 'C++'
Version: '10.0'
Location: 'C:\Program Files\Microsoft Visual Studio 10.0'
Details: [1x1 mex.CompilerConfigurationDetails]

Sign in to comment.

Accepted Answer

MarkB
MarkB on 23 Mar 2011
I believe that this occurs if you are using Visual Studio Express. When Simulink creates a VS solution/project, it actually does it through some COM/ActiveX interface that is only present on Visual Studio Professional Edition. As a result, you can't make Visual Studio solutions/projects with the Express Edition.

  6 Comments

Show 3 older comments
Kaustubha Govind
Kaustubha Govind on 24 Mar 2011
Ajay: Since you are already in contact with Tech Support - could you please have them put in an enhancement request to update the documentation? They will be able to handle your request more appropriately. Thank you!
Kenny
Kenny on 14 Jan 2013
I have Visual Studio Professional 2010 (evaulation trial) installed and I can't create any Visual C++ Solution File (grt.tlc, ert.tlc or grt_malloc.tlc) with the Visual C++ complier. I've selected mex to the Visual C++ 2010 Professional complier package. I got the exactly same error "No supported Visual C/C++ compiler found. Check your installation of Visual C/C++." when trying to build RTW. Can anyone help me?
Kaustubha Govind
Kaustubha Govind on 15 Jan 2013
If you're on a 64-bit machine, you might need to install the x64 Compilers and Tools package at the time of installing Visual Studio. Also, when you run "mex -setup", make sure that the utility can automatically locate the installed compiler. If you have to specify it manually, there's something wrong with your compiler setup. Also, make sure that your version of MATLAB supports that version of Visual Studio: http://www.mathworks.com/support/sysreq/previous_releases.html (last column)

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!