MATLAB Answers


Matlab stop/crash/not work when i try to start Simulink

Asked by chiara farnesi on 1 Feb 2018
Latest activity Commented on by rayane benyoucef on 21 May 2019
Hi to every one,
I had installed Matlab2017b on Ubuntu 14.04 some days ago. When i try to start Matlab Simulink all the program stops to work and shows this error line on the terminal:
*Error in `/usr/local/MATLAB/R2017b/bin/glnxa64/MATLAB': corrupted size vs. prev_size: 0x00007f59e8192ab0*** Segmentation Fault
How can i fix this problem?
Thanks to all.


I have the same problem.
Ihave the same problem too :(

Sign in to comment.

3 Answers

Answer by Nick Sarnie on 19 Jun 2018
Edited by Nick Sarnie on 19 Jun 2018
 Accepted Answer

Hi everyone,
This is believed to caused by a bug in glibc 2.19, the default in Ubuntu 14.04. The upstream bug report can be found below:
The bug can cause sporadic crashes during various actions within MATLAB.
As a workaround, I recommend upgrading Ubuntu versions to a version with glibc 2.21 installed by default, or working with the Ubuntu community to upgrade the glibc version on 14.04 to 2.21 or later.
If you still run into issues after upgrading glibc to 2.21 or later, please contact Technical Support.


Sign in to comment.

Answer by Ecems SSumer on 7 May 2018

I have the same problem. Is anyone know how to solve it? I am using Ubuntu 14.04 and Matlab2018a.


I have the same problem. Did anybody get the solution?
I am facing exactly same problem with Ubuntu 14.04 and Matlab2018a. I downloaded twice, still no luck.
same problem here. can anyone post how to upgrade glibc because I can't upgrade my ubuntu version because of some softwares am working with.

Sign in to comment.

Answer by Jakub Popielarz on 22 Mar 2018

Hello, Have you solved this issue? Regards,

  1 Comment

I had same problem when I installed Matlab2018b on Ubuntu14.04 but it works well now on ubuntu 18.04. just upgrade

Sign in to comment.