MATLAB Answers

uigetdir not working in standalone application

9 views (last 30 days)
I have created a gui which uses uigetdir in one of the pushbuttons and it works in matlab application, but when converted to standalone application the 'select directory' is not showing up. Any idea to what should be done?

  3 Comments

Geoff Hayes
Geoff Hayes on 14 Jun 2018
Udit - please claraify what you mean by the select directory is not showing up. Is this the path that you are passing in (as an input parameter) to uigetdir? Are you passing the full path to the selected directory or is it a relative path?
Udit Dhand
Udit Dhand on 14 Jun 2018
I got the application to work, the error was not with uigetdir but with a report that was not compilable, when i complied the application. I used makeDOMCompilable() as a work around and now it works. Sorry for wasting your time.
Image Analyst
Image Analyst on 14 Jun 2018
Still, if you're using R2018a, you will have a problem, as I mentioned in my Answer below.

Sign in to comment.

Accepted Answer

Image Analyst
Image Analyst on 14 Jun 2018
This is a known bug in release R2018a.
You either have to use the workaround they suggest, or go back to R2017b.

  3 Comments

Victor Gonzalez
Victor Gonzalez on 13 Jul 2018
In update 4 the bug is listed as fixed, have you tried it? In my code didn't worked, I have to still use the workaround
Image Analyst
Image Analyst on 13 Jul 2018
I haven't yet. Maybe I'll try this weekend.
Anton Kullberg
Anton Kullberg on 19 Jul 2018
It works for me using update 4. Try reinstalling update 4 perhaps?

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!