"An error occurred while creating an instance of connectivity configuration" When I do the PIL with F28069.

18 views (last 30 days)
JiangHong Wu
JiangHong Wu on 8 Aug 2018
Answered: Hassan Abouobaida on 11 May 2021
this is error I met when I use my F28069 ISO controlcard to do PIL:
my top model and configuration:
my reference model ,the configuration is the same as top_model:
supplement:
I have been set this param on the command line:
>> setpref('MathWorks_Embeded_IDE_Link_PIL_Preferences','BaudRate','115200') >>setpref('MathWorks_Embedded_IDE_Link_PIL_Preferences','COMPort','COM8') >>setpref('MathWorks_Embedded_IDE_Link_PIL_Preferences','enableserial','true')
could you help me please?
  2 Comments
S Saha
S Saha on 25 Jul 2019
I am finding same problem with PIL application,,,,,
Cannot perform a processor-in-the-loop (PIL) simulation for "rtwdemo_pmsmfoc".
The configuration parameters for this model do not support the following connectivity configurations: ARM Cortex-A9 (QEMU), Texas Instruments C2000 Base, XILINXZYNQ, Texas Instruments Code Composer Studio (IDE), Texas Instruments Code Composer Studio (TCP/IP), Texas Instruments Code Composer Studio (Serial), Microchip connectivity using UART, Microchip PIC32 connectivity using UART, Arduino connectivity config using serial, TI LaunchPad connectivity config using Serial
To fix this error, update the configuration parameters or create a supported connectivity configuration. See Configure a SIL or PIL Simulation, Create a Connectivity Configuration for a Target, and Processor-in-the-Loop (PIL) Simulation in your product help.

Sign in to comment.

Answers (2)

DIPAYAN  SAHA
DIPAYAN SAHA on 25 Jul 2019
I am also get similar error in above as you shown and i also try to solve as per your recommendation but i get some other error.....
#####
Cannot perform a processor-in-the-loop (PIL) simulation for "rtwdemo_pmsmfoc".
The configuration parameters for this model do not support the following connectivity configurations: Texas Instruments C2000 Base, Texas Instruments Code Composer Studio (IDE), Texas Instruments Code Composer Studio (TCP/IP), Texas Instruments Code Composer Studio (Serial)
To fix this error, update the configuration parameters or create a supported connectivity configuration. See Configure a SIL or PIL Simulation, Create a Connectivity Configuration for a Target, and Processor-in-the-Loop (PIL) Simulation in your product help.
#####
I have a question on your above response that after solving your error the PIL mode is running in your hardware?

Hassan Abouobaida
Hassan Abouobaida on 11 May 2021
Hello,
I get the same error, please help me.
................................................................................................................................
### Build procedure for model: 'Control' aborted due to an error.
Error using rtwbuild (line 301)
Cannot perform a processor-in-the-loop (PIL) simulation for "Control".
The configuration parameters for this model do not support the following
connectivity configurations: ALTERASOCSIM, XILINXZYNQSIM, Texas Instruments
C2000 Base, Texas Instruments Code Composer Studio (IDE), Texas Instruments Code
Composer Studio (TCP/IP), Texas Instruments Code Composer Studio (Serial)
To fix this error, update the configuration parameters or create a supported
connectivity configuration. See Configure a SIL or PIL Simulation, Create a
Connectivity Configuration for a Target, and Processor-in-the-Loop (PIL)
Simulation in your product help.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!