MATLAB Answers

Failed to connect to the target f28069M in matlab simulink.

18 views (last 30 days)
hi everyone,
ı want to use f28037 external mode but simulink gives below error.
matlab version 2017b, ccs v7 is used. out file of simulink works at ccs but external mode gives error.
error is ;
Error occurred while executing External Mode MEX-file 'ext_comm': Failed to connect to the targetFailed to connect to the target. A time-out occurred while waiting for the connection response from the target. Possible reasons for the time-out:
a) The target is not switched on.
b) The target is not connected to your host machine.
c) The application for the model is not running on the target. You might have clicked the Stop button. If the Run button is not dimmed, click it. Otherwise, click the Build button, which downloads and runs your application on the target.
how to solve this error??????
(before this usb port not recognized by device manager after I solved that problem by using following steps
At control panel-> device manager->Texas instrument probes
I select each of item click at properties, go to advance tab and marked load VCP checkbox.)

Accepted Answer

Venkatesh Chilapur
Venkatesh Chilapur on 5 Dec 2018
Please verify the MUX settings on the board and GPIO values in hardware configuation in Simulink.
You need have UART enabled on GPIO29 and 28. That is option 2 from table and the jumper settings for JP6 and JP7.
And the same GPIO needs to selected under SCI_A pane in simulink.
dhanushka thennakoon
dhanushka thennakoon on 6 Dec 2018
wow its work..
thank you sooo much..I didnt see full image of yours.Now I set the all the jumpers as you properly works.thank you very much your corporation.
best regards,

Sign in to comment.

More Answers (2)

Mehmet AKAR
Mehmet AKAR on 1 Oct 2019
Hello Venkatesh chilapur, I have Drv8301 hc c2 kit with 28069 card. I am trying to control pmsm at sensorless mode. Firstly i used ti universal gui and motor was operated correctly. Then i tried to operate with simulink but i can't. I used simulink 28069 dual examples. Model was build succesfuly but motor doesnt start. Can you help about this subject. Is there any example with Drv8301 hc c2 kit? Kindest regards Dr Mehmet Akar

Haris Ç
Haris Ç on 3 Feb 2021
Dear Venkatesh Chilapur,
I have a LaunchpadXL TMS320F28069M card. I am trying to use external mode in Simulink. I removed the JP6 and keep the rest jumpers as illustrated in your figure. However, I could not manage to run my simulink correctly. Maybe, I could not entirely configurate the hardware (baudrate, SCI_A etc.).
Could you please share a simulink file which is organized for the external mode operation?
Best regards,
Dr. Haris C.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!