MATLAB Answers

Fedora 30 matlab start issue

99 views (last 30 days)
tzycce
tzycce on 17 Apr 2019
Edited: Nima shafiee on 31 Jul 2019
I'm running Fedora 30 beta and the installation process went smoothly with default settings. However it won't boot and I get the following error:
"MATLAB is selecting SOFTWARE OPENGL rendering.
/usr/local/bin/matlab: line 1233: lsb_release: command not found
/usr/local/MATLAB/R2019a/bin/glnxa64/MATLAB: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory"
Libcrypt.so.1 is part of glibc package which is already installed as glibc-2.29-9.fc30.x86_64.
Why doesn't matlab find this package?

  0 Comments

Sign in to comment.

Accepted Answer

Ayan Banerjee
Ayan Banerjee on 18 Apr 2019
Fedora 30 ships with libcrypt version 2. R2019a requires libcrypt version 1. By running dnf provides libcrypt.so.1, we can see that the legacy version 1 is provided by the package libcrypt-compat. You have to just install this package using dnf (dnf install libcrypt-compat).

  4 Comments

Show 1 older comment
Menno Hofste
Menno Hofste on 23 Apr 2019
For me the package name was libxcrypt-compat, note the x.
Andrew Cavanaugh
Andrew Cavanaugh on 2 May 2019
That was the package for me, however I still get the same error when trying to open Matlab (even post re-boot). I'm sure re-installing Matlab will fix it, but that seems excessive.
Lucas Hermann
Lucas Hermann on 3 May 2019
had the same issue, thank you so much!

Sign in to comment.

Sign in to answer this question.