MATLAB Answers

SOLVED: Unable to Upload Firmware to Pixhawk; Firmware image not found

59 views (last 30 days)
Joshua O'Reilly
Joshua O'Reilly on 31 May 2019
Commented: July on 8 Apr 2020
EDIT: SOLVED
See the bottom comment for the solution
---
I've been following the setup steps for the PX4 Autopilots Support from Embedded Coder package. I was able to succesfully build the firmware (nuttx_px4fmu-v2_default.cmake), however when trying to upload it to the actual board, I get the following error:
Firmware upload failed: Firmware image not found. Please build the firmware again.
I've rebuilt the firmware a dozen or so times now, including the lpe variant, and I always get this error. The COM port is properly identified, and I used the appropriate version for everything (Ubuntu 16.04 WSL, PX4 v1.8.0, MATLAB R2018b along with all required packages). In the command prompt it indicates
BUILDSTARTING_31-May-2019_10-08-01
CMAKE Config selected : px4fmu-v2_default
After building the firmware. Any clue why this is happening/how to resolve it?
I'm running MATLAB on Windows 10 1803, using a Pixhawk board (condensed version of Pixhawk 1)

  6 Comments

Show 3 older comments
a a
a a on 5 Aug 2019
hi !
i have a same problem...
i did uninstall ubuntu 16.04 wsl and reinstall it, but did not resolve this problem.
how can i resolve this problem?!

Sign in to comment.

Accepted Answer

Joshua O'Reilly
Joshua O'Reilly on 12 Jul 2019
Edited: Joshua O'Reilly on 5 Feb 2020
Copying my comment down here:
Got it to work!
It turns out that, if the firmware build fails, it won't tell you why. I ran the build command from here:
make px4_fmu-v5_default
(for the Pixhawk 4, seperate commands can be found for other models)
After running the make command, I was told exactly what library was missing (don't remember which anymore), and I installed that library directly from the command line (for ubuntu, sudo apt install libraryname). I was then able to build and upload the firmware successfully through MATLAB

  0 Comments

Sign in to comment.

More Answers (0)

Products


Release

R2018b