MATLAB Answers

'ga' function - change in feasibility check of linear constraint > R2016b

3 views (last 30 days)
Frank Niessen
Frank Niessen on 22 Jul 2019
Commented: Frank Niessen on 30 Jul 2019
Hi everyone,
I have been writing a program that solves an optimization problem (rotation of one vector out of a specific group of vectors onto a second vector with rotational constraints). This worked quite well in MATLAB 2016b using the 'ga' function. As I want to make my code accessible for users of older versions of MATLAB as well I installed MATLAB R2014a and R2015a to check the downward compatibility of my code. It turned out that the convergence of the 'ga' algorithm was nothing like running the code in R2016b. When running with the older versions the solver would run into a local optimum quite abruptly and get stuck there, sometimes even violating the constraints ('Linear constraints are not satisfied within constraint tolerance'). This has never occured in 2016b.
I found this release note for 2016b:
Linear Constraints in ga and patternsearch: Different algorithm
When there are linear constraints in a problem, the ga and patternsearch solvers internally use linprog to ensure feasibility. In previous releases, the solvers internally used the linprog 'active-set' and 'simplex' algorithms. However, these algorithms were removed in R2016b. So the solvers now use the linprog 'dual-simplex' and 'interior-point' algorithms.
Compatibility Considerations
When your problem has linear constraints, your ga and patternsearch results can differ from previous versions. This difference is likely to be inconsequential.
I tried to check different starting parameters for the ga algorithm in the older versions but am not able to get it to converge smoothly. Is there anythin I can do to get a better behavior of my code for ga versions < R2016b?
Thank you for your help
Frank
ga.JPG
R2014a vs. R2016b

  0 Comments

Sign in to comment.

Answers (2)


Ganesh Regoti
Ganesh Regoti on 30 Jul 2019
There was a bug fix between 14a and 16b related to ga function. Refer this
Hope this helps!

  1 Comment

Frank Niessen
Frank Niessen on 30 Jul 2019
Hi Ganesh,
thanks for the suggestion. I checked this bug, but it is not what is causing the problem in my case (I have an initial population of 100, so an EliteCount of 5 by default).

Sign in to comment.

Sign in to answer this question.

Products


Release

R2016b