MATLAB Answers


Matlab cannot access my gpu Cuda Device

Asked by Ren
on 25 Jul 2019
Latest activity Commented on by Ren
on 26 Jul 2019
Colleagues, hello!
I am using matlab 2018b with cuda 9.1 installed. I tried to try the command gpuDeviceCount returns 1 and when I used the command gpuDevice to get the properties of the CUDADevice , I got :
There is a problem with the graphics driver or with this GPU device. Be sure that you have a supported GPU and that the
latest driver is installed.
Caused by:
The graphics driver was found, but it is too old. The graphics driver on your system supports CUDA version 7.5. The
required CUDA version is 9.1 or greater.
When i used command system('nvcc --version') I got
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2017 NVIDIA Corporation
Built on Fri_Nov__3_21:08:12_Central_Daylight_Time_2017
Cuda compilation tools, release 9.1, V9.1.85
ans =
Then I used the command nvcc --version but I got error Undefined function or variable 'nvcc'.
i dont get the prb here why matlab 2018b does not recognise NVIDIA GPU Card in my laptop when the supported cuda toolkit 9.1 is installed !!!!
I am working under windows 7 and my graphic cards are Intel (R) HD Graphics 520 and NVIDIA GeForce 920M.


Sign in to comment.

1 Answer

Answer by Edric Ellis
on 26 Jul 2019
Edited by Edric Ellis
on 26 Jul 2019
 Accepted Answer

nvcc is part of the CUDA toolkit, and in fact you do not need any version of that to successfully use gpuArray in MATLAB. It is just the CUDA driver that you need, that's what the error message is complaining about. To get the latest CUDA driver, you need to go here: and get the latest driver for your system. (It's generally the right thing to do to get the latest driver available for your system. You need the toolkit portion if you wish to build MEX functions that access mxGPUArray functionality).


on 26 Jul 2019
Ah ok now I understand thank you for that, I installed the lastest version of the cuda driver and while using parallel.gpu.GPUDevice.getDevice(1) I got
Then I tried parallel.internal.gpu.CUDADriverVersion and I got error
Error using parallel.internal.gpu.CUDADriverVersion
Could not find the CUDA driver named 'nvcuda.dll'.
Well, providing gpuDevice works correctly, I wouldn't worry too much about parallel.internal.gpu.CUDADriverVersion - that's a debugging tool that is not used by the gpuArray implementation.
on 26 Jul 2019
thank you! useful

Sign in to comment.