MATLAB Answers


How to Compile an Application with the "pspectrum" function?

Asked by Jeff
on 1 Aug 2019
Latest activity Answered by Jeff
on 26 Aug 2019
I am trying to compile an application that uses the "pspectrum" function (I think it is from the Signal Processing toolbox), but I am having trouble with including the right files in the compiler. I have attached a screenshot of my compiler and the error message I am getting from my compiled application. Are there any other / different files that I should be including in the compiler, or are there other issues that need to be addressed here as well?


Tried that before but was getting the same error. I moved that function to our file path and added it to the compiler, and got a new error message that I attached to this message.
Does anyone know where "signalanalyzer.internal.Spectrogram" is defined? I cannot find it in the functions that I'm looking at in the MATLAB toolbox folders.
My latest update in compiling is attached. I compiled the pspectrum.m and signalAnalyzer.m files and the "signal" toolbox folder. Now I need to include "coder", which I was unable to do by compiling with the entire "coder" toolbox folder.

Sign in to comment.

2 Answers

Answer by Jeff
on 26 Aug 2019
 Accepted Answer

After speaking with a MATLAB representative, we found that the issue is that the pspectrum function cannot be compiled with the MATLAB Application Compiler in versions before 2019a.


Sign in to comment.

Answer by Sean de Wolski
on 19 Aug 2019

  • The signalAnalyzer app is not compilable.
  • You shouldn't have to do anything to compile pspectrum, it should just work. Do you have a license for signal processing toolbox checked out at compile time?
  • You may need to run: rehash toolboxcache

  1 Comment

The application I am trying to compile references pspectrum so I have been trying to compile with a number of file required to run. The latest error I get when I add the entire signal toolbox folder is the "Undefined variable "coder" or class "coder.internal.isCompiled"." error when I am running the part of my application that uses pspectrum.

Sign in to comment.